Bookmarks lost whenever location bar history cleared

RESOLVED INVALID

Status

SeaMonkey
Bookmarks & History
--
critical
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Gary T. Leavens, Assigned: Pierre Chanial)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707

When I select Edit/Preferences... and under the Navigator tree click on history
and then press the button in the Location Bar History section labeled "Clear
Location Bar", all of my bookmarks disappear when I then quit and restart.

Reproducible: Always
Steps to Reproduce:
0. Save your bookmarks in a file by slecting Bookmarks/Manage Bookmarks... and
then from the window that pops up, Tool/Export...  (This isn't really necessary
to show the problem, but helpful for afterwards. :-)
1. From the browser (Navigator) select Edit/Preferences...
2. Under the Navigator tree click on History
3. Press the button in the Location Bar History section labeled "Clear Location Bar"
4. Exit the browser (File/Exit)
5. Start the browser again

Actual Results:  
The bookmarks stored in the main menu's Bookmarks item are gone.

Expected Results:  
Cleared location bar history information only, not my bookmarks too.

This is related to the meta-bug 203343.  I can't find any other bug that is
directlly related.

My bookmarks are stored in C:\Documents and Settings\leavens\Application
Data\Mozilla\Profiles\default\rxuyper0.slt\bookmarks.html
There is a separate history.dat file there.
(Reporter)

Comment 1

14 years ago
I was sure that the steps given make the bookmarks be lost, but trying it yet
again I can't reproduce the problem.  I'm sorry, but I will try to figure out
what really causes this to happen.  Perhaps the history has to be a certain
size?  I don't know.  Sorry for the bother.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.