left click image zoom does not refresh the cursor

VERIFIED DUPLICATE of bug 20022

Status

()

Firefox
Disability Access
--
trivial
VERIFIED DUPLICATE of bug 20022
14 years ago
13 years ago

People

(Reporter: Valerij Rozouvan, Assigned: Aaron Leventhal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

When Firefox resizes images to fit the window, the cursor is a magnifying glass
with a minus or a plus sign on it. When you left click on the image, the image
either resizes to original size, or back to fit the screen. However, unless you
move the cursor, it does not refresh and either plus or minus is seen no matter
how many times you click.

Reproducible: Always
Steps to Reproduce:
1. Make sure the browser will resize all images to fit the window.
2. Open a large image (http://diggler.mozdev.org/screen7.png).
3. Left click (unless you move the cursor, it does not change from minus to plus
or vice-versa).

Actual Results:  
Unless the mouse was moved the cursor was not refreshed to display the plus or
the minus no matter how many times you click.

Expected Results:  
The browser should change the cursor every time you click.

Comment 1

14 years ago
Probably fixed on trunk by Bug 20022 checkin a while back

Comment 2

14 years ago
Sounds like it, this fix doesnt exist in brach builds, please repopen if you
disagree

*** This bug has been marked as a duplicate of 20022 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.