error -8101 (certificate corrupted) occurs if I open web-site with mozilla browser & mail using ssl

RESOLVED DUPLICATE of bug 231775

Status

NSS
Libraries
--
major
RESOLVED DUPLICATE of bug 231775
14 years ago
14 years ago

People

(Reporter: Hannelore Kohl, Assigned: Wan-Teh Chang)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

If I want to visit https://mail.epost.de/ using mozilla 1.7en following error
occurs:
"Could not establish an encrypted connection because certificate presented by
mail.epost.de is invalid or corrupted. Error Code: -8101"

If I use Internet Explorer everything works fine..

btw the certificate was changed 5 days ago - before that everthing was fine..
same behavior occurs using mozilla-mail..

sometimes - but very very seldom - i can work around this problem by clicking
hundreds of times on "get new messages" in mail&newsgroups..

Reproducible: Always
Steps to Reproduce:
1. visit https://mail.epost.de/ or connect using secure-pop3 or secure-smtp
Actual Results:  
error -8101 occurs almost evertime

Expected Results:  
show the web-site correctly - as it did before (and as IE6 does)..

others got the same bug (also with different web-sites)..
http://forums.mozillazine.org/viewtopic.php?t=99200&highlight=8101&sid=5bc6d5c0a3d52667069323c4ee75955b
http://forums.mozillazine.org/viewtopic.php?t=104401&highlight=8101&sid=5bc6d5c0a3d52667069323c4ee75955b
-8101 seems to be:
138 SEC_ERROR_INADEQUATE_CERT_TYPE              =   (SEC_ERROR_BASE + 91),

324 "Certificate type not approved for application.")

Changing bug product to NSS.   NOT confirmed.
Whether this is a bug, or the certs really are invalid 
remains to be determined. 
Assignee: dveditz → wchang0222
Component: Security: General → Libraries
Product: Browser → NSS
QA Contact: bishakhabanerjee
Version: Trunk → 3.9

*** This bug has been marked as a duplicate of 231775 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.