Links with visibility: hidden are still 'there'.

VERIFIED DUPLICATE of bug 12232

Status

()

P3
major
VERIFIED DUPLICATE of bug 12232
19 years ago
19 years ago

People

(Reporter: coonsta, Assigned: joki)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
<A href=...> elements with visibility: hidden are still 'there': they can still
be navigated, still generate events (e.g. mouse over, etc.).

It doesn't matter if the element is made invisible by a style sheet or
dynamically by a script, nor does it matter if the visibility is inherited from
a parent.

I first noticed this in M12 and it still exists in M13.

I have classified this as major since many sites rely on hidden elements not
being navigable/firing events, and the spurious events could severly hamper user
interaction on dynamic sites.
(Reporter)

Comment 1

19 years ago
Created attachment 4630 [details]
Page that demonstrates the problem.

Comment 2

19 years ago
Tom, event problem. Pretty sure it's a DUP
Assignee: troy → joki
(Assignee)

Comment 3

19 years ago
yeah, dupe of 12232

*** This bug has been marked as a duplicate of 12232 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 4

19 years ago
Marking verified dup of 12232.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.