[AltSS] remove alternate stylesheet UI

VERIFIED FIXED

Status

()

Firefox
General
VERIFIED FIXED
13 years ago
3 years ago

People

(Reporter: asa, Assigned: Blake Ross)

Tracking

({access, fixed-aviary1.0})

1.0 Branch
access, fixed-aviary1.0
Points:
---
Bug Flags:
blocking-aviary1.0PR +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
The alternate stylesheet support is incomplete, buggy, and has serious UI
problems including accessibility. This feature isn't ready for prime time,
doesn't offer a significant benefit to the user, fails to even match the basic
functionality offered by in-content switching mechanisms (discoverability,
cookie-based persistence, etc.) and could easily be added by a Firefox extension
(see the work going on at http://www.robtougher.com/servlet/web.index already). 

We should pull this UI for Firefox 1.0 and if we can make it work better and
expose it in a more useful way for our users, then add it back for Firefox 1.5.
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.0?
(Reporter)

Comment 1

13 years ago
see also bug 216537, bug 253332, bug 216424, bug 224250, bug 220649, bug 83663,
and bug 220975. 

In addition to the bugs, I just don't think this is worth the extra UI and user
confusion given its limited value. I see the chicken and egg problem here but I
think we've already lost that battle. Web pages have their own UI for this and
it works just fine. Our UI doesn't work just fine and sticks out as a confusing
and somewhat broken feature in our primary browser interface.

Comment 2

13 years ago
Seems to me like the missing, long overdue, basic function to use no stylesheet
at all (bug 32372) would belong in this UI.
Keywords: access
Version: unspecified → 1.0 Branch

Comment 3

13 years ago
I am planning to fix all those bugs except the selection-persistence ones for
the 1.0 localization freeze (FF 0.10?). The main reason is, as Felix notes, the
"disable author styles" function belongs with the AltSS UI. That switch /needs/ to
be available through the menus (not the prefs) or else it's useless.

If you absolutely must have selection-persistence before 0.10, I can give it a
shot as well. Won't be anything fancy like the one described in 83663, but I
might be able to do something very basic.
Summary: remove alternate stylesheet UI → [AltSS] remove alternate stylesheet UI
Stylesheet persistence is available as an extension as of about a week ago, if
it's any help in implementing it.  The extension appears to fix bug 83663 and
bug 216537, although I haven't tested it enough to say for sure that it does
these (and does them well):

http://update.mozilla.org/extensions/moreinfo.php?id=192&vid=387&category=Page%20Display

Comment 5

13 years ago
Fantasai, in case you are going to add persistent style sheet support, I added a
whole slew of ideas to bug 216537 based on the issues and questions I
encountered using Jeff's extension in practice. I hope they will be useful in
implementing and tweaking the functionality of style sheet persistence, be it
for the 1.0 release of Firefox or after that :).

As a final note, it would be a shame if the stylesheet selector were to
disappear from the next release of Firefox. So I'm glad you're giving it
attention, fantasai :). Also, I'm looking forward to the additional
functionality ('No theme' on every site, etc).


~Grauw
(In reply to comment #5)
> I added a whole slew of ideas to bug 216537 based on the issues and questions
> I encountered using Jeff's extension in practice.

Just by way of clarification, it's not my extension, it's Rob Tougher's
extension.  (Sorry for the bugspam.)

http://snurl.com/rob_tougher
(Reporter)

Comment 7

13 years ago
It was decided at the last aviary meeting that this feature would be removed for
1.0.  We'd like to see this done right as part of trunk Firefox work to unify
site-specific settings. UI for this should be removed prior to shipping Firefox
PR1.  Blake, can you help with this? 
Flags: blocking-aviary1.0? → blocking-aviary1.0PR+

Comment 8

13 years ago
sad, really sad
(Assignee)

Comment 9

13 years ago
Created attachment 156824 [details] [diff] [review]
patch
(Assignee)

Comment 10

13 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 11

13 years ago
I haven't noticed any bugs or problems with this, but I can appreciate
incompleteness as a reason for removing this UI just now, though I really hope
this is fixed up soon.

However, I certainly don't agree that it should be removed in favour of
in-content prefs.  I honestly see very few sites that allow this kind of choice
inline, and even then, they tend to be reliant on JavaScript and of course have
a non-consistent UI.

Looking at the w3c, they recommend such a UI, including the ability to remove
CSS entirely; again, a feature that in-content mechanisms don't provide.
http://www.w3.org/TR/html4/present/styles.html#h-14.3.1

Comment 12

13 years ago
For those of you interested in having the style sheet switching functionality
for 1.0, I'll be adding a graphical interface to my extension some time this week:

http://robtougher.com/servlet/web.news.show_item?date=8-23-2004%207:38%20PM

I'd be happy to hear any suggestions or comments.
I just can't believe you removed this, alternate stylesheet selection being a
**mandatory** conformance criterium of CSS 2 for user agents applying stylesheets.
This is ridiculous. So many blogs offer alternate stylesheets...

Comment 14

13 years ago
(In reply to comment #0)
> The alternate stylesheet support is incomplete, buggy, and has serious UI
> problems including accessibility. This feature isn't ready for prime time,
> doesn't offer a significant benefit to the user, fails to even match the basic
> functionality offered by in-content switching mechanisms (discoverability,
> cookie-based persistence, etc.) and could easily be added by a Firefox extension
> (see the work going on at http://www.robtougher.com/servlet/web.index already). 
> 
> We should pull this UI for Firefox 1.0 and if we can make it work better and
> expose it in a more useful way for our users, then add it back for Firefox 1.5.


The css2 support is incomplete and buggy (just browse bugzilla).
This feature isn't ready for prime time, doesn't offer a significant benefit to
the user wich is anyway accustumed to css1-half-compliant browsers, and fails to
even match the basic design possibilities offered by in-content pictures

[...]

You should pull css2 support of [immediately] and if one can make it work better
then add it back in twenty years.

You can also remove any support for remote xul, cause it's also buggy and
incomplete.


And yes, this is sarcastic.

But frankly... what's next Asa? Jsconsole, viewsource, stylesheetswitching.

I switched from IE two years ago; at that time I was barely able to write html.
I switched to Moz *because* view source was nicier than notepad, *because* I
began understanding Js with the jsconsole *and because* I fall down from my
chair when I first met stylesheet switching on texturizer.net


Do you seriously think stylesheet switching *confuses* users?
What is this sick retoric?
First you were the one *rudely* saying you never saw *keyboardless users* (in
comments to the infamous remove jsconsole/viewsource ui bug)

And now you want to make us believe users are *brainless*.
How do they use keyboards? Throwing rocks at it?

I'm not upset by your decisions. I used to respect them, especially when not
sharing.
But I'm upset by the *huge* amount of plain lies you send out to make them look
like *sensitive* decisions.

Either find a way to be credible, or be a true dictator, for the best and the
worst, and stop sending ****** at us.


And give me a keyboard from these users of you, mine will contribute brains back.




Regards.

Olivier
(In reply to comment #14)
> 
> Either find a way to be credible, or be a true dictator, for the best and the
> worst, and stop sending *crap* at us.
> 
> 
> And give me a keyboard from these users of you, mine will contribute brains back.
> 

Personal attacks really aren't warranted, nor accepted by the Mozilla community.
 It's not appreciated, and not helpful.

Comment 16

13 years ago
Just to balance out the flood of naysayers no doubt forthcoming: As much as I
hate to see it go, this was the right call. Let's leave the half-implemented,
buggy features to the extension authors. I just think you should have cited bug
254287 as the real reason for removal. :)

Comment 17

13 years ago
(In reply to comment #15)
> (In reply to comment #14)
>   
> Personal attacks really aren't warranted, nor accepted by the Mozilla community.
>  It's not appreciated, and not helpful.

This I can understand.
So how do you call this:
http://bugzilla.mozilla.org/show_bug.cgi?id=256213#c15

A *non* personnal *non* attack?

Comment 18

13 years ago
*sobs softly*

So no chance that if fantasai gets some serious work done on this, it will get
back in before 1.0? :( Rob: you're the man ;p. Sorry I misattributed your extension.

Comment 19

13 years ago
Maby 1.0 should be just gecko installer, and than browser as an extension to it?
:] If we want to get IE functionality on the end of this way you should quickly
remove some othr features :]

Comment 20

13 years ago
You have got to be kidding.
Ditto Danial Glazman's comments.
Put it back.
(Assignee)

Comment 21

13 years ago
The next person who comments in this bug that has nothing relevant to say about
the bug itself is asking to have his Bugzilla account disabled.

I have started a discussion thread at the MozillaZine forums where you can
discuss the removal of this feature and make your case for its return if you're
so inclined. It's located at
http://forums.mozillazine.org/viewtopic.php?p=743566#743566. The Firefox team
reads the forums.
Status: RESOLVED → VERIFIED

Comment 22

13 years ago
(In reply to comment #14)
> I switched from IE two years ago; at that time I was barely able to write html.
> I switched to Moz *because* view source was nicier than notepad, *because* I
> began understanding Js with the jsconsole *and because* I fall down from my
> chair when I first met stylesheet switching on texturizer.net

+ing this ! 
I think it can't wait till Fx 1.5 ! Could it be replanned ?

Comment 23

13 years ago
In the description Asa says that the alternate stylesheet is not persistent, isn't this the way we want 
it to be?

If you want a persistent change in your current style, then use the JS based switcher given by the 
site, otherwise use the one given by Firefox/Application Suite. 

(We even might like the option(!) to make the change given by the user in the FF style sheet 
switcher persistent, but it's not a requirement - at tleast not for FF 1.0) - I.E. a persistent change 
requires you to check a checkbox before the menu option and a non persistent change is done by 
selecting the item from the menu. (However I'm not sure if this is desirable or if its possible)

About the accessibility, how much effort will it take to create a menu option just like SeaMonkey 
has? - This will add some work for l10n, but if you add this option before de l10n frees this 
shouldn't be a problem...
(Reporter)

Updated

13 years ago
Keywords: fixed-aviary1.0

Comment 24

13 years ago
It's obvious that many people are annoyed with this decision, so isn't there a
way to compromise?  Although I don't see exactly what bugs are serious enough to
warrant its removal (except *maybe* the lack of persistence), is it possible to
leave it as an option that can be turned on if the user wants to, but off by
default?  That way, existing users that were happy with it could turn it on and
continue to use it (I certainly would, I use it nearly every day without any
problems!), and new users won't be exposed to its problems; not that I can see
any but apparently there are.

Comment 25

13 years ago
Shouldn't there be a dependency tree for this bug? Why not make it a tracking
bug for the switcher, if the cause for the removal of the feature is the severe
bugs affecting the function?

Comment 26

13 years ago
(In reply to comment #21)
> The next person who comments in this bug that has nothing relevant to 
> say about the bug itself is asking to have his Bugzilla account disabled.
> 
> I have started a discussion thread at the MozillaZine forums where you can
> discuss the removal of this feature and make your case for its return 
> if you're so inclined. It's located at
> http://forums.mozillazine.org/viewtopic.php?p=743566#743566. The Firefox 
> team reads the forums.

Well, if this threatens my Bugzilla account, then so be it. But after reading 12
pages of that MZ thread, I see very few good arguments for removing the feature
(even temporarily) and many compelling reasons for NOT removing it. It is nice
to know that the Firefox team reads the forums, but it would be much better if
they would actually participate in the discussions and reply direct questions. I
am very interested in hearing any response from the devs to all the arguments in
favour of keeping the alternate stylesheet switcher, especially now that PR1 is
looming. For some reason this response hasn't come yet, even when several people
(including myself) have explicitly and repeatedly asked for it in that MZ
thread. Any updates?





You need to log in before you can comment on or make changes to this bug.