Showing/hiding Find Toolbar makes all open tabs reflow immediately

RESOLVED DUPLICATE of bug 227361

Status

()

Toolkit
Find Toolbar
--
enhancement
RESOLVED DUPLICATE of bug 227361
14 years ago
10 years ago

People

(Reporter: Tim De Pauw, Assigned: Blake Ross)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040729 Firefox/0.9.1+ (bangbang023)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040729 Firefox/0.9.1+ (bangbang023)

[#firefox]
[23:24] <sp3k> hm. firefoxes newish find bar thingy is hideously slow to start
up when you have lots of tabs
[23:24] <blake> start up?
[23:24] <sp3k> can't recall taf being that slow in the same case
<...>
[23:26] <sp3k> well, takes more than a second for me with about 20 tabs
<...>
[23:37] <[ct]> sp3k, Jesse, blake: the find toolbar resizes _all_ open tabs' body
[23:37] <blake> it shouldnt do that upon opening tho
[23:37] <[ct]> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040729 Firefox/0.9.1+ (bangbang023)
[23:37] <blake> I guess it kinda has to
[23:38] <[ct]> i just alt-entered data:text/html,<body onresize="alert('hi');">
a couple of times
[23:38] <[ct]> then hit ctrl-f
[23:38] <[ct]> and got lots of hi's :)
<...>
[23:38] <[ct]> well it doesn't really have to
[23:38] <[ct]> you can cache the dimensions when the tab was last shown
[23:39] <[ct]> and have it reflow if necessary once it's shown again
[23:39] <[ct]> correct me if i'm wrong

I asked blake if I should file a bug for future reference, but he must've missed
it, so I'm filing it anyway.

Reproducible: Always
Steps to Reproduce:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040730
Firefox/0.9.1+

WFM

AMD850-512Mb 20 tabs open

Comment 2

14 years ago
Steps to reproduce:
1. Load data:text/html,<body onresize="alert('hi');"> in a bunch of tabs.
2. Ctrl+F.

Results: A bunch of dialogs.
Expected: One dialog.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: perf
David, didn't you look into something like this a while ago?

/be
So this bug should affect all platforms.

/be
OS: Windows XP → All
Hardware: PC → All

Updated

14 years ago
Blocks: 261870
You're probably thinking of bug 227361.  We really need a better notion of
"hidden"-ness on the docshell or something like it.
dbaron: jst used a docshell notion of visibility in the workaround just landed
for bug 124750 -- is that not helpful here and in bug 227361?  The last patch in
bug 227361 doesn't use the API jst used, AFAICT.

/be

Comment 7

14 years ago
Looks like bug 258917 is a dupe of this one?
Depends on: 227361
(Assignee)

Comment 8

13 years ago

*** This bug has been marked as a duplicate of 227361 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
No longer blocks: 261870
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.