download manager progress summary averages unweighted percentages

VERIFIED DUPLICATE of bug 239006

Status

()

Toolkit
Downloads API
--
trivial
VERIFIED DUPLICATE of bug 239006
14 years ago
10 years ago

People

(Reporter: knoepfle, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

When downloading more than one file, the download manager reports progress in
its title (e.g. "58% of 2 files - Downloads") but the percentage represents a
simple average of the percent done of each file.  Thus, the figure is a poor
representation of overall progress.

Reproducible: Always
Steps to Reproduce:
1. Start downloading a large file
2. Start downloading a smaller file
3. Open the download manager and watch the percentage in the title shoot up
quickly as the small file downloads, then fall back down abruptly when it completes.



Expected Results:  
Calculate a weighted average, taking into account filesize.  Unless, of course,
this behavior is intentional.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 239006 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.