Closed Bug 25397 Opened 20 years ago Closed 20 years ago

Basic text and table page displays different size fonts then 4.x

Categories

(Core :: Layout, defect, P3)

x86
Windows 95
defect

Tracking

()

VERIFIED DUPLICATE of bug 21950

People

(Reporter: johng, Assigned: pierre)

References

()

Details

Go to http://client/seamonkey/navigator/search-home.htm using Seamonkey.
Go to same web page using Navigator 4.7

Notice that the font size of the text in the Seamonkey build is much larger then
what you have in Navigator 4.7.  That is wrong, and messes up content provider's
ability to create pages that look good on different browsers.  This is
particulary problematic for Netcenter creating My Sidebar panels.

M13 01-25 build 2000012520
Component: Browser-General → XP Toolkit/Widgets
QA Contact: nobody → paulmac
This can only be addressed in the chrome, probably in global.css and/or
navigator.css, which are locked down for changes except through their owner. 
Moving from "B-G" component to "XP Toolkit/Widgets", not knowing who better to 
send this to.

Also, currently the base font size for everything in Mozilla is specified in
mm, so scaling of display device physical dpi, stubbed in at Edit>Preferences>
Appearance>Fonts>Font Scaling, may be relevant for content providers used to
thinking in terms of a specific number of pixels for the size of the navigator 
fonts ... if this gets implemented fully.
This has nothing to do with the chrome or with XPToolkit.  This is a problem 
with HTML.  It should be given to rickg and Gecko.
Possibly I'd have been less likely to put my foot in my mouth if I'd been able
to view the testcase... sorry.

Moving to "Layout" and assigning to rickg as suggested.
Assignee: nobody → rickg
Component: XP Toolkit/Widgets → Layout
QA Contact: paulmac → petersen
The table looks fine to me, but the fonts are a little bigger. I know that 
pierre has an issue here, so I'll reassign this to him.
Assignee: rickg → pierre


*** This bug has been marked as a duplicate of 21950 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Marking as verified dup of 21950.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.