Plugins not dynamically re-sizeable via javascript ".width=" or ".style.width="

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
14 years ago
3 years ago

People

(Reporter: ken2006, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.1) Gecko/20040707

The follwing two javascript/DOM call variants do not work:
window.document.getElementById("RVOCX").width=640;
window.document.getElementById("RVOCX").style.width=640;

The do actually set the new value, but the plugin does not change size.

These call do work on at least one other browser (ie), but not apparently on
Mozilla.

Reproducible: Always
Steps to Reproduce:




This may seem like a trivial function, however without it a page-reload is
required, which has the obviousy effect of re-initing the plugin, and page
content must be refreshed.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 2

13 years ago
Verified this is still not working in Deer Park..
Duplicate of this bug: 382957
Bug 382957 has another testcase.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

6 years ago
Priority: -- → P3

Comment 5

6 years ago
Can this possibly be true? Minimal testcase please!
Flags: in-testsuite?
Keywords: qawanted, testcase-wanted
bug 90268 probably fixed this if not before

Updated

6 years ago
Flags: needinfo?

Comment 7

5 years ago
Windows 2000 support has been dropped a while ago. Please only reopen this bug if you can reproduce it on Windows XP or older with current Firefox builds.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?
Resolution: --- → WONTFIX
Ioana, there appears to be nothing win2k-specific about this bug.  Please don't resolve bugs as wontfix based on their (bogus, automatically set by Bugzilla) OS field without actually trying to reproduce them.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 9

5 years ago
Comment 0 specified clearly Win2k (see user agent) and I didn't see any other OSs specified in comments, it wasn't just the OS field.

Is there a specific OS you want this tested on?

Comment 10

5 years ago
Ioana, since most bugs don't depend on particular Windows versions, it's not considered good practice to resolve a bug just based on a particular version unless it's clear that it only affects the particular version.

That said, the obvious thing to do with this bug is write a small testcase for it and see whether you can reproduce it. It's likely that bug 90268 fixed it, and we could mark it INCOMPLETE based on that; or use WORKSFORME if you can write a testcase and don't see an issue with resizing.
Status: REOPENED → UNCONFIRMED
Ever confirmed: false

Comment 11

5 years ago
Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20100101 Firefox/25.0

There already is a test case for this bug in the duplicate, bug 382957. That test works fine for me. I also modified it to try style.width and that resized the plugin content well too.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.