If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

DIV border overlaps content when DIV is dynamically resized

RESOLVED FIXED

Status

()

Core
Layout: R & A Pos
--
minor
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Julian Turner, Assigned: mats)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 

Connected with bug report 151181

See also http://forums.mozillazine.org/viewtopic.php?t=108567

If you have two nested DIVs, both with borders. The inner DIV contains a P with 
sometext.  If you dynamically resize the outer DIV, the inner DIV border is 
resized, so that it overlaps its contents.




Reproducible: Always
Steps to Reproduce:
1.  Create an Outer DIV with width set and overflow hidden or auto.
2.  Create an Inner DIV with a border set.
3.  Insert into the Inner DIV a P with lots of text and white-space:nowrap, or 
alternatively a P with a border and width set.
4.  Dyamically resize the outer DIV so that its width is less than the width of 
the P contained in the Inner DIV.



Actual Results:  
Inner DIV border overlaps child P text.

Expected Results:  
Presumably Inner DIV border should not change - as in IE.
(Reporter)

Comment 1

13 years ago
Created attachment 155153 [details]
Demonstration of DIV border overlapping on resize.
(Assignee)

Comment 2

13 years ago
Pretty sure this is a dupe of bug 201897, marking dependant for now.
Status: UNCONFIRMED → NEW
Component: Layout: Block and Inline → Layout: R & A Pos
Depends on: 201897
Ever confirmed: true
Keywords: testcase
OS: Windows 2000 → All
QA Contact: core.layout.block-and-inline → core.layout.r-and-a-pos
Hardware: PC → All
(Assignee)

Updated

13 years ago
Assignee: nobody → mats.palmgren
(Assignee)

Comment 3

13 years ago
-> FIXED (by bug 201897)
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.