From: selection list needs more flexibility

VERIFIED DUPLICATE of bug 44863

Status

MailNews Core
Composition
--
enhancement
VERIFIED DUPLICATE of bug 44863
13 years ago
9 years ago

People

(Reporter: Richard Dunlap, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

The From: selection list only allows users to select the address of an account
managed in Mozilla.  This becomes a problem when, for example, multiple email
forwarding addresses are being coalesced into a single physical address, and it
is overkill to give each forwarding address its own Mozilla account (think
home/academic usage rather than business usage).  The problem is trying to send
an outbound email with a selected forwarding address in the From: line.

Simple solution: Auto-completion rather than a pull-down list, allowing the user
to override the selections.
Harder solution: Maintaining a list of known aliases for each physical account
and adding them to the selection list.

Caveat: The feature makes it easier to spoof the From: line on an email address
-- with that in mind, the second solution is better than the first.

Reproducible: Always
Steps to Reproduce:

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 44863 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.