If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

no find feedback with ctrl-G & shift-ctrl-G

RESOLVED FIXED

Status

()

Toolkit
Find Toolbar
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: Michael Clackler, Assigned: Blake Ross)

Tracking

({fixed-aviary1.0})

unspecified
x86
Windows XP
fixed-aviary1.0
Points:
---
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [have patch])

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040802 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040802 Firefox/0.9.1+

When using ctrl-G & shift-ctrl-G there is no find status indicated to the user
(not found/find wrapped).

Reproducible: Always
Steps to Reproduce:
1. Open the find bar and enter a string that will not be found.
2. Close the find bar
3. press ctrl-G

Actual Results:  
Nothing Happens

Expected Results:  
User gets an indication that the find is not found.
(Reporter)

Comment 1

13 years ago
Created attachment 155400 [details] [diff] [review]
patch to fix

This patch provides feedback to the user when using ctrl-G and shift-ctrl-g.  

If the find "wraps" top or bottom, the find bar will open to display the
wrapped status.  If the find is "not found" the find bar will open to display
the not found status.  The "not found" sound will also sound once each time
ctrl-g or shift-ctrl-g is used for a not-found string.

The "wrap" and "not found" status indications will time-out using the standard
find bar timer.  The "wrap" indication will also close if ctrl-g or
shift-ctrl-g is used again before the 5 second timer expands.
(Reporter)

Updated

13 years ago
Attachment #155400 - Flags: review?(firefox)
(Reporter)

Comment 2

13 years ago
requesting blocking-aviary1.0/PR since patch exists
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0?

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

13 years ago
Whiteboard: [have patch]
(Assignee)

Comment 3

13 years ago
Michael, thanks for the patch. We talked this over and decided that we shouldn't
show the toolbar in the case of wrap since that's not all that important and the
old find dialog didn't do that. We also don't think people will see the wrap
status. However, we do like the idea of showing the toolbar (with the bright red
textbox) in the case where it's not found. Can you modify the patch to only show
on not-found, not on wrap?
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0+
(Reporter)

Comment 4

13 years ago
Created attachment 156559 [details] [diff] [review]
patch with only Not Found status

Making the status only show on "Not Found" greatly simplifies the patch.

This patch will open the find bar with the 5 sec timer when using ctrl-g or
shift-ctrl-g if the find string is not found.  The "not found" sound will also
be heard every time ctrl-g or shift-ctrl-g is used with a "not found" string.
Attachment #155400 - Attachment is obsolete: true
(Reporter)

Comment 5

13 years ago
Created attachment 156560 [details] [diff] [review]
patch with only Not Found Status

Attached the wrong past in prevoius post.  This is the correct one
(hopefully!).
Attachment #156559 - Attachment is obsolete: true
(Reporter)

Updated

13 years ago
Attachment #155400 - Flags: review?(firefox)
(Reporter)

Updated

13 years ago
Attachment #156560 - Flags: review?(firefox)
(Assignee)

Comment 6

13 years ago
Comment on attachment 156560 [details] [diff] [review]
patch with only Not Found Status

Hi Mike,

Thanks for the updated patch. Talked this over with Asa again and he brought up
one more good point: If you were in typeaheadfind mode when you hit ctrl+g,
this toolbar should disappear after 5 seconds. Can you modify your patch to do
that and I'll r=?
Attachment #156560 - Flags: review?(firefox) → review-
Flags: blocking-aviary1.0PR?
(Reporter)

Comment 7

13 years ago
(In reply to comment #6)

> If you were in typeaheadfind mode when you hit ctrl+g,
> this toolbar should disappear after 5 seconds. 

Blake,

Could you please explain a little more what you are looking for, I don't quite
understand.  The code in this patch does nothing with the "Not Found" status
indication if the findbar is visible (i.e. if you're in typeaheadfind mode). 
When the findbar closes, the find mode is changed to normal.  The reason the
patch changes the find mode to typeahead is so that the close timer will set in
order for the bar to close after 5 sec (find must be != normal).

Basically, with this patch if you use ctrl-g for a "not found" string when the
findbar is hidden, the bar will open and then close 5 sec after the last toolbar
action.  If ctrl-g is used for a "not found" string when the find bar is open by
any means (ctrl-f, FAYT, /, or ') the bar will react as it allways has (w/
ctrl-f the bar will stay open, with all others the bar will close 5 sec after
the last findbar action).

Basically, no matter what (unless the bar is opened with ctrl-F), the find bar
will close after 5 sec using ctrl-g.
(Assignee)

Comment 8

13 years ago
I just checked in a fix for this. Thanks, Mike, for the help.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

13 years ago
Created attachment 157011 [details] [diff] [review]
"Not Found" sound w/ ctrl-G

Blake,

For consistency shouldn't we also sound the "not found" sound when a "not
found" string is requested using ctrl-G?  Your checkin yesterday allows the
find bar to open with the "not found" indication but we do not get the audible
indication we get all other times we request a bad find string.

This patch is the part of my previous patch that enables the "not found" sound
using ctrl-g and shift-ctrl-g if the find string is not found.
(Reporter)

Updated

13 years ago
Attachment #156560 - Attachment is obsolete: true
(Reporter)

Updated

13 years ago
Attachment #157011 - Flags: review?(firefox)

Comment 10

13 years ago
> We talked this over and decided that we shouldn't show the toolbar in the case
> of wrap since that's not all that important

I think this feedback is VERY important, at least for one specific case. If a
search term is only found on a page once, ^G should give feedback that eaither
"The search has wrapped", or better, something more specific to the situation,
such as "The only occurance is already selected", except less technical.

I was bit by this just yesterday. A compile was running in the background, so
Firefox was very slow responding to user interaction. I kept hitting ^G to
search for a word in a few different tabs, but it seemed as if it was ignoring
everything but the first press. If I understand what was checked in here, this
case is still unimproved.

Comment 11

13 years ago
I'm using aviary 20040831. Although the fixed-aviary-1.0 flag is not set, I see
the "Phrase not found" and the associated icon next to it. The text inside the
search field is red. But I don't see the toolbar vanishing after 5 secs. Steps
to reproduce:
1. Ctrl+F a not existing word
2. close Find Toolbar
3. Ctrl+G

Updated

13 years ago
Flags: blocking-aviary1.0PR?

Updated

13 years ago
Keywords: fixed-aviary1.0

Updated

12 years ago
Attachment #157011 - Flags: review?(firefox)

Updated

12 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 12

12 years ago
Sorry about that.  I see that you intended to only fix the most annoying side-effects of this bug.  I only meant to add myself to the CC list, not change the status.

Resetting status to FIXED.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → FIXED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.