If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Download speed calculated incorrectly if download not confirmed immediately

RESOLVED DUPLICATE of bug 245725

Status

()

Toolkit
Downloads API
--
trivial
RESOLVED DUPLICATE of bug 245725
13 years ago
9 years ago

People

(Reporter: Kevin Karan, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

The speed is calculated after the download confermation dialog as gone and the
download has been passed to the download manager. So, since the timer is started
in the download manager, any received data will be factored into the speed
equasion and the speed will be shown at some impossable speed and will eventualy
go down to the correct speed.

Reproducible: Always
Steps to Reproduce:
1.Start a download for a very large file
2.Leave confermation dialog opened up for 5 or more minutes
3.Conferm the download sot it will be handed off the the download manager

Actual Results:  
An impossable speed will be shown.

Expected Results:  
Started the timer when the download actualy started and not when the download
manager started.
(Reporter)

Updated

13 years ago
Summary: Download speed calculated incorrectly if download not confermed imediatly → Download speed calculated incorrectly if download not confirmed immediately

*** This bug has been marked as a duplicate of 245725 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.