Margin-bottom duplication when hovering over elements which changes overflow to hidden

RESOLVED WORKSFORME

Status

()

Core
Layout: Block and Inline
--
minor
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040808 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040808 Firefox/0.9.1+

Originally discussed here:
http://forums.mozillazine.org/viewtopic.php?t=107531

See upcoming testcase.
In that testcase, you should not see a shifting of the 'text' blocks when they
are hovered over, but it does currently in Mozilla.
The cause of this seems to be the div:hover{overflow:hidden} rule. It seems to
cause a duplication of the size of the margin-bottom it currently has.


Reproducible: Always
Steps to Reproduce:
1. See testcase. Hover over 'text' blocks
2.
3.

Actual Results:  
'Text' blocks move down.

Expected Results:  
They should stay right where they were.
(Reporter)

Comment 1

14 years ago
Created attachment 155492 [details]
Testcase

Comment 2

14 years ago
Bug occurs all the way back to Mozilla 1.0.2 (inclusive)
Severity: normal → minor
Keywords: testcase
OS: Windows XP → All
(Reporter)

Comment 3

14 years ago
I'm not seeing the bug anymore in:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040919
Firefox/0.9.1+

This was most likely fixed by the fix for bug 257612.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

14 years ago
Depends on: 257612

Comment 4

13 years ago
Workaround for Gecko 1.7 builds: trigger reflow after a slight delay.

For example:

setTimeout(function() {
   some_element.style.height = '0';	//trigger reflow
   some_element.style.height = 'auto';	//undo change
}, 0);
You need to log in before you can comment on or make changes to this bug.