focus lost when window comes to front

VERIFIED DUPLICATE of bug 12051

Status

()

P3
normal
VERIFIED DUPLICATE of bug 12051
19 years ago
17 years ago

People

(Reporter: warrensomebody, Assigned: saari)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
If you start typing in the URL bar and then go to another app and come back 
(e.g. Alt-Tab to something else on Windows, and then Alt-Tab back to the browser 
window), you'll see the cursor still blinking in the URL bar, but when you try 
to type, nothing happens.

Either (1) the blinking cursor should stop blinking (because it gives you the 
impression that that field still has focus), or (2) the focus should return to 
where you left off.

I vote for (2), although trying this with 4.x, I've found that the location bar 
reverts back to its old text before you started modifying it (that seems wrong 
to me). Another point of reference: If you alt-tab back to a mail compose 
window in 4.x, the focus stays where it was in the message pane, but if you were 
typing in the subject line, it doesn not (!).

In all cases, I vote for (2) -- text fields, location bar, mail compose subject, 
body, address widget, etc.

Comment 1

19 years ago
I think may be a dup of 12051

Comment 2

19 years ago
assigning this to saari so he can determine if this really is a dup of 12051
Assignee: beppe → saari
(Assignee)

Comment 3

19 years ago
This is a dup of 12051.

The cursor no longer blinks on MacOS and Windows. Linux is being difficult, but 
hopefully I get it fixed next week. Sometime not far after that, we will fix 
12051 and the focus will be remembered and reset when you bring the window back 
to front.


*** This bug has been marked as a duplicate of 12051 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 4

19 years ago
verified duplicate of 12051 - Focus not saved
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.