If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Keyboard focus lost when user navigates with the keyboard and plug-in slides under mouse pointer

RESOLVED DUPLICATE of bug 95541

Status

()

Core
Keyboard: Navigation
RESOLVED DUPLICATE of bug 95541
13 years ago
13 years ago

People

(Reporter: Olivier Glassey, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2) Gecko/20040308
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2) Gecko/20040308

Keyboard-only navigation may bring some plug-in content under the mouse pointer,
in which case focus will be lost to the plug-in. 

Reproducible: Always
Steps to Reproduce:
1. The mouse pointer must be near the middle of the content window. We will now
use the keyboard only for navigation.
2. Go to a web page that displays an article and a Flash advertisement in the
middle, but somewhat down the page (not on the first screen), for example
http://www.technologyreview.com/articles/04/09/roush0904.asp. Make sure the
advertisement is in Flash (reload the page if necessary until you get a flash
advertisement).
3. Navigate down the page using the down arrow.
4. At some point, navigating down the page will make the Flash content slide
under the mouse pointer and keyboard focus will be lost for navigation.

Actual Results:  
Keyboard focus lost. Must use mouse to regain focus.



Expected Results:  
Keyboard focus should not change when plug-in content slides under mouse
pointer. If the mouse is moved into the plug-in content, I agree focus should be
lost to the plug-in.
Even if some tabbing is implemented for moving focus between plug-in content and
page navigation, I think focus should not be lost when plug-in content slides
under mouse pointer. In keyboard-only navigation, results should not depend on
mouse pointer location.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 95541 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.