substituting a semicolon for a colon in http results in all web traffic being redirected to microsoft.com

VERIFIED DUPLICATE of bug 231720

Status

()

Firefox
General
--
trivial
VERIFIED DUPLICATE of bug 231720
14 years ago
13 years ago

People

(Reporter: Fibbi, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1 StumbleUpon/1.995
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1 StumbleUpon/1.995

When you enter a url, if you accidentally(or intentionally, as the case may be)
substitute a semicolon for a colon in "http", any url gets redirected to
microsoft.com

examples include:
http;//www.mozilla.org
http;//www.slashdot.org

Reproducible: Always
Steps to Reproduce:
1.enter a url
2.change http:// to http;//
3.press enter

Actual Results:  
it goes to microsoft.com

Expected Results:  
some sort of error, or more helpfully, automatically treating it as if it were a
colon.
http://http is owned by Microsoft so your mistype will result in a search for that.

*** This bug has been marked as a duplicate of 235478 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 231720 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Verifying old and obvious dupes. Sorry for bugspam.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.