overwrite files if clicked on an item in the save as dialog, keep filename checkbox solution!

VERIFIED WONTFIX

Status

()

Firefox
Shell Integration
VERIFIED WONTFIX
14 years ago
9 years ago

People

(Reporter: Aaron Peterson, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040810 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040810 Firefox/0.9.3

This behavior is in windows and kde... and it wasn't in firefox (as far as I
remember) but now it's there... and I have one less reason to use firefox..

basically, When I am downloading a web page, I must find a place to save it! 
and that involves lots of file managing, and mouse wrangling,   If I click on
the wrong file (not a folder)  the file name in the save as dialog will switch
to that file!  I might be wanting to overwrite one file, but If I clock on
another file, I'd be expecting the overwrite dialog.. and BLAMMO  lost work

I've lost work in kde because of this behavior of having a single click change
the file name...

It's absolutely wrong behavior, and I woudn't even have double click do it, but
the proper way to deal with this problem is to:

1. have double click a file change the to be saved as filename
2. have the option to have single click in about:config
3. have the option to have a button on the side change filename to selected file
name.
4 have option to do nothing on double, and single click...

this is highly important, as support for the disabled, (in this case everybody)
is so important to the choice of a platform.

if 5 percent of the people can't use it
but only 2 percent of the people can't use the competetor, the 95 percent will
likely work with the software that supports that additional 3 percent of the
population...

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




this is major, because it causes loss of work...  LOTS of work on occasion I
lost an important file (yes I should be backing up) due to this bug, and I'm
scared to think of how anybody else can deal with the save as dialog without
overwriting something...

Comment 1

14 years ago
*** Bug 255603 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Assignee: aaronleventhal → bugs
Component: Accessibility → OS Integration
Keywords: dataloss
QA Contact: bugzilla → firefox.os-integration
Reasons to not fix this bug:

a) The only filepicker we control is the XUL filepicker under GNOME.  This will
only be used by older Linuxes with GTK < v2.4.  So any fix will be of limited
value, since Windows etc will still have it.
b) All filepickers I've ever used act like this, so its expected behaviour,
anything else would be a usability loss.
c) Your suggested UI is painful and ugly.
d) This has nothing at all to do with accessibility.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

14 years ago
Reason a for not fixing is the only one I'm sympathetic to... Ironically, I'm 
using KDE, and I still get the gnome file dialog... or is it gtk?  anyway, If 
its "Upstream" I'll point my rage at gnome, which I already think should die 
for single click destructive power.  
 
a) The only filepicker we control is the XUL filepicker under GNOME.  This 
will 
only be used by older Linuxes with GTK < v2.4.  So any fix will be of limited 
value, since Windows etc will still have it. 
 
 
b) All filepickers I've ever used act like this, so its expected behaviour, 
anything else would be a usability loss. 
 
This is never expected behavior.. its always unexpected and unfortunate. 
 
They ALL need to change,   I will settle for an option to make the program 
sane, as user configuration is generally expected... because there are lots of 
kooky developers who get off on having end users waste their lives piddling 
away at the computer screen, redoing work...  but I ain't gonna use software 
that facilitates overwriting of arbitrary files. 
 
 
 
c) Your suggested UI is painful and ugly. 
Well, I agree that the extra button, if placed incorrectly would be ugly, but 
it sure ain't  as painfull as loosing a weeks worth of work. (which I 
basically did, because I overwrote an older version of a file that I would 
have reverted to...) 
 
d) This has nothing at all to do with accessibility. 
This, is where I'd punch you if I were in the same room as you, however, lets 
try to get some mediation on this issue. 
 
1. Limited eyesight 
  I can't see the difference between a few characters easily!! 
2. Limited motor skill 
  I can't move the mouse perfectly all the time, I missclick occasionally. 
 
3. The behavior that really want is: 
single click just highlights the software.. 
double click, opens folders 
double click on a file ... can make the "overwrite" confirmation pop up like 
it currently does... 
 
but an option to  rename the file (if clicked in correct spot) would be 
nicer.. 
 
4. Double clicks are for accessibility reasons... they lower the chance of 
accidentally doing things... it's a built in "are you sure" 
 
Single clicks can do stuff, but only when there is an indication that 
something is going to happen, such as a cursor change, or a button ... 
"wiggle" -- focus indication 
 
I will reopen this till kingdom come, this is on my list of computer 
misbehavior all time worst list, and It's cost me enough time, that I must 
ethically fight for at least an OPTION to turn it to sane (in my definition) 
behavior.   
 
I believe in letting you write over your work if you want to, and if you're a 
super mouser, with >20/15 eyesight and never get tired, then have fun with 
your split second optimization.  
 
I do intend to getting around to making a patch if nobody else is willing to 
fix this travisty...   It'll be a while, but ASSIGN THE BUG TO ME if you don't 
want it it tarnishing your bug reputation. 
 
 
 
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
We're not here to reinvent the wheel.  This is how filepickers work across
multiple platforms.  If you do convince the world to change, we'll certainly
change to match, but until that time, no.

You've already said that you click on the wrong file, which is where the problem
comes in.  If you're meaning to do something, making it double-click instead
will have very little impact, because the problem is in your inability to
differentiate.  If you deliberately choose a file from the list in order to
overwrite it, the HOW doesn't matter if the problem lies in your inability to
differentiate between the filenames.  You're still able to make the exact same
mistake, and ignore the warning, and lose your files.  All you've done is make
it mechanically more difficult to make that same set of bad decisions (not
verifying the filename that you've clicked on).  Most HIGs explictly avoid
forcing double-click on users BECAUSE of accessibility.  Making the process
harder to perform is not going to be a net accessibility win.

You can make this about some personal "bug reputation" however its about
application design and consistency with other apps.  Also, I don't respond well
to threats of violence, and if you keep up, you'll just end up getting your
bugzilla account suspended.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

14 years ago
Please keep this bug open, but assign it to me, alpeterson@wsu.edu. I will 
upload patches when I create them, and I'm sure other people have this 
difficulty as well. 
 
  You are blaming my non supreme capabilities on me, If I were fully in 
control over myself, I would be God. 
 
I am available via telephone at 509 332 7697, and my IM accounts are: 
incinerated@yahoo.com  aaron_pet@hotmail.com ICQ:2302806  
 
I am quite confident that double clicking was designed for accessibility 
purposes, where accessibility means allowing a person to do thing that they 
want to do on the computer, and not do things that they don't want to do. 
 
SELECTING A FILE TO OVERWRITE IS DANGEROUS 
and it should not be a single click operation. 
 
I can select files just fine, save as is NOT THE PLACE TO SELECT FILES!!! 
 
The problem is, WHEN I'M SAVING SOMETHING, I DON'T WANT TO BE OVERWRITING 
SOMETHING ELSE  having the file name change on me..similar is NOT OK,  yes, it 
prompts me if I want to overwrite, but then I have to go back to the web page, 
and reload the web page, and navigate AGAIN!!! 
 
I've been using computers for a long time, and I have only recently started 
seeing this atrocious behavior... 
 
I could have sworn that windows didn't do this before... I think some people 
got lazy in their code reuse recently.. as the SAVE AS dialog is not the same 
as an  OPEN dialog. 
 
Just leave it open assigned to me, or to nobody, or whatever, but just PLEASE 
let this be noted as a problem viewed by at least me. 
 
I don't want to get my account suspended, but this is very important! 
 
******* ******* 
I view bug closure of this form as violence, I must rise above, but I don't 
always.  My physological responce to your reply included those of somebody 
being attacked.  I tried to indicate as such.  This is a real issue. 
I probably would not have punched you in the face, but I don't respond well to 
personal attacks on myself, especially when I am trying to do the right thing. 
 
>You can make this about some personal "bug reputation" however its about 
application design and consistency with other apps.  Also, I don't respond 
well 
to threats of violence, and if you keep up, you'll just end up getting your 
bugzilla account suspended. 
 
 
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
There is no point in leaving this bug open as we are not going to accept a patch
for it.  I discussed this bug yesterday with one of the primary accessibility
hackers, who agreed with my decision here.  While I can understand and respect
your point of view, that does not mean we are obligated in any way to accept
that, or a patch to change the behaviour.  Please do not take this as a personal
insult in any way.

You do have to keep in mind that as a major usability rule, we attempt to behave
in the same way as common system dialogs on the platform we're on.  Failing to
do so will only result in user confusion, and unexpected behaviour has a severe
effect on accessibility.  GTK, KDE, Windows, and  OS X save as dialogs all
behave like this, so the vast majority of users are/should be used to this
convention.  Debating the merits of this behaviour is ignoring the fact that we
are simply following OS convention, as we do in countless other places.

With regard to double-clicking as an action:
"Double-clicking is most commonly used as a shortcut for other actions, such as
pressing Command-O to open a document or dragging to select a word. Because not
everyone is physically able to perform a double click, it should never be the
only way to perform an action." - Apple HIG

GNOME has similar guidelines.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

14 years ago
verified wontfix? 
 
interesting...  I plea for somebody to contact me to help make a plugin...  It 
shouldn't be too hard? or is the file browser thing in there really deep?  
anyway.. this problem needs to be fixed on all components... 
 
interesting that you would cite Apple and gnome... 
 
Apple is the opposite of a paramount for userfriendlyness...  They make you 
move a mouse from one end of the screen to the other... or use both hands to 
do an operation  (or buy a multi buttoned mouse).  I can't use both hands all 
the time... and the most common operation on scrolling on web pages... (well.. 
maybe not on macs because of their huge displays!) and that's what the middle 
mouse button is for (yay! firefox has autoscroll!) 
 
and Gnome, is the easiest way to destroy your system.. they should pattent 
single click system destruct!!  the gdm config pannel did instant changes to 
the config file...  that's BAD, as while looking through the options, and 
clicking exit caused the system to NOT WORK. 
 
 
Apple does have multiple options, and I agree that double clicking is not 
possible for a lot of people... BUT THAT IS THE POINT!!!  for INFREQUENT / 
DANGEROUS operations doubleclicking + menu operation is appropriate! 
 
I'm going to try to talk with people on freedesktop and KDE and other 
places... heck Microsoft and Apple...   I'm not just picking on Firefox.. I 
just thought that firefox is above the crud...    
 
If anybody is interested in helping me make a patch, that can be used as a 
plugin, please contact me...  I'll even try to scrape some $ together if 
somebody needs to be paid... 
 
I KNOW you arn't obligated to accept patches... but please don't just dismiss 
it without trying it...    
 
With regard to double-clicking as an action: 
"Double-clicking is most commonly used as a shortcut for other actions, such 
as 
pressing Command-O to open a document or dragging to select a word. Because 
not 
everyone is physically able to perform a double click, it should never be the 
only way to perform an action." - Apple HIG 
 
True True...  that's why i mentioned having a menu item or a button to select 
the file for overwriting...  
 
Aw.. ***# it, reopening... I felt like leaving it closed, but I refuted all of 
your points...  
 
I've put so much time into Mozilla Firefox, (promoting it, installing it on 
other peoples computers, setting bookmarks and testing nightlies, and 
filing... what i think are thoughtfull bug reports)    That I'm shocked that 
you won't just assign the bug to me, or to a "nobody" account...  Wash your 
hands of it.. but let me use this as a place to post patches... and 
collaborate with my friends that I've convinced this to..   
 
 
 
Status: VERIFIED → UNCONFIRMED
Resolution: WONTFIX → ---
(Reporter)

Comment 8

14 years ago
hah! I can reassign to myself!!   
   
Sorry, i forgot that I could do that...   ... but I can't... it comes off as a  
"I can't switch it to new"  
(Reporter)

Comment 9

14 years ago
http://bugs.kde.org/show_bug.cgi?id=69676 
is the kde bug.. and I didn't submit it... 
I don't know how many times it's been submitted and closed WONTFIX so there is 
no duplicate record...  
 
anyway.. I'm finding bug reports on other components... 
Like I said, if you can convince the major platforms (GNOME/KDE) on Linux to
change their default behaviour, we'll change the XUL picker to match.  We are
not here to make the rules for a platform.  We just follow their rules to behave
well with their platform.  That is the key point here, that you have refused to
acknowledge.  Until then, for the third or fourth time, we are not going to take
action on this bug.  You're not refuting my points, you're ignoring them.

If you want to make an extension that changes this behaviour, great, but that
happens outside of Bugzilla.  It still won't do anything on Windows unless you
convince Microsoft to change their native filepicker, since we use native
dialogs throughout the app on Windows.

Marking WONTFIX.  If you reopen this for a fifth time, your Bugzilla account
will be suspended.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

13 years ago
Created attachment 159300 [details]
There is no way to tell that I am actually downloading firefox, or something like opera

This image demonstrates, that, there is no mechanism to be sure that I am
actually downloading what I say I am downloading. I could be downloading pr0n
or Opera, or KDE... and  my cat could have accidentally clicked on the firefox
binary name, and as I'm downloading a nightly, This is a file that I want to
overwrite... 

[I could be downloading two things at once, firefox and opera for example)
and.. opera overwrites firefox... incidentally opera segfaults.. so you guys
still have the superior browser :) ]

anyway, there is no indication of what is being downloaded,

The save as dialog for a web browser is not the same as word processor save-as
dialog... they can be very similar, but they server different tasks... The
browser has a responsibility to represent reality in what it's doing.

in a word processor, a person has to choose the filename
(Reporter)

Comment 12

13 years ago
Created attachment 159303 [details]
lock that filename down. -- as it could be

in this one, there is a visually simple mod (probably fairly simple to
implement) , that would, if checked, keep the name locked down as the original
file name.

allowing the user to visually know that the filename is the same as it was on
the server, so when that user needs to search vis desktop, or archive directory
for that huge file, ve can know that ve isn't clobbering vis homework, or
favorite web browser..

(checked demostration not shown..)
simpler solution is still to read the warning dialog.  Or use the setting to
automatically download to a folder, since that a) downloads using the filename
and b) doesn't overwrite existing files.
(Reporter)

Comment 14

13 years ago
>simpler solution is still to read the warning dialog.  
?? an altimatum, that either gets clicked hastily because it is a common 
annoyance, or ignored, because it APPEARS that it's ok to overwrite firefox... 
even though I'm downloading opera... so then I have no firefox on my system 
when I am on my slow net connection.. so I don't get to use firefox. 
 
 Or use the setting to 
automatically download to a folder, since that  
 
>a) downloads using the filename 
Rarely downloads using the filename, because the file already exists, and 
there is an occasion to overwrite files... one just doesn't likely want to 
overwrite the wrong file...  
 
and b) doesn't overwrite existing files. 
Causes multiple downloads of the same file because one fears that ve didn't 
receive it...  
 
And, presently, renames files in a way that will cause a person to not 
download part 2 of a file if the file was already downloaded... 
part-1-big_file.zip downloaded twice gives: 
part-2-big_file.zip 
 
Causing lots of problems. 
 
If it renames it as intended, there will still be problems... 
 
Basically, I spent a lot of time talking with people, and thinking of a 
solution. 
 
I have been admonished for the "punch in the face" comment above, and I do 
regret that responce, and apologize...   
 
This is an important feature, and I am attempting to get other projects to add 
a similar feature... 
 
It's most important for WEB BROWSERS though, or other interfaces which involve 
copying others' work. 
 
--Good day 
(Reporter)

Comment 15

13 years ago
Ah, I agree that double clicking is an awkward solution for this, summary 
changed to reflect the long thought out solution. 
 
(my LUG has been giving me a hard time for the "punch in the face" comment, 
but they still discussed the issues and we came to that checkbox idea) 
Summary: overwrite files if clicked on an item in the save as dialog, should be double click to select → overwrite files if clicked on an item in the save as dialog, keep filename checkbox solution!
Without trying, at all, to be confrontational, you need to accept the following
as the final word on this bug and work in the appropriate direction to push for
this significant change to a VERY longstanding convention:

The XUL filepicker is designed to act like default WM filepickers (i.e.
GNOME/KDE) on Linux.  It would represent a severe usability issue if we decided
to reinvent the wheel as to how common platform elements behaved, even if we're
implementing our own version in XUL.  If GNOME and KDE change their behaviours
to match what you're suggesting, we'll certainly follow suit, but we are not
going to break platform conventions in the meantime.
(Reporter)

Comment 17

9 years ago
Mike, wow, Seeing this years later, Thanks for being so civil. You helped by bringing up good arguments. I'm sad that I haven't convinced people to include fixes to these issues. You convinced me that this isn't the place to fix it, and I'm sorry it took so long for me to understand that.
You need to log in before you can comment on or make changes to this bug.