Default Cache Directory is in Wrong Place in File System

VERIFIED DUPLICATE of bug 74085

Status

()

Core
Networking: Cache
--
enhancement
VERIFIED DUPLICATE of bug 74085
13 years ago
13 years ago

People

(Reporter: Chris Warrington, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)

The default cache directory is placed under the "Application Settings" 
directory within the user's home directory. It should be under the "Local 
Settings" directory like Internet Explorer's is. This prevents users with 
roaming profiles from having large profiles which increases network bandwidth.

Reproducible: Always
Steps to Reproduce:
1. Install Mozilla
2. Let it create a profile in the default directory


Actual Results:  
The cache is stored in "C:\Documents and Settings\%username%\Application 
Data\Mozilla\Profiles\default.???\Cache"

Expected Results:  
The cache should be stored in "C:\Documents and Settings\%username%\Local 
Settings" somewhere. Perhaps under "Mozilla\Cache\<Cache System Version>" so 
that multiple Mozilla software products (Mozilla & Firefox really) can use the 
same cache if the caching systems are the same.

The is only a real problem for Windows users who have roaming profiles.

Updated

13 years ago
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 74085 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.