Last Comment Bug 255667 - Permission denied in frames on same domain
: Permission denied in frames on same domain
Status: RESOLVED WORKSFORME
: regression, testcase
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: 1.7 Branch
: x86 Windows 98
: -- major (vote)
: ---
Assigned To: general
:
:
Mentors:
Depends on: 434522
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-15 03:53 PDT by bht237
Modified: 2010-10-28 09:18 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Testcase (1.30 KB, text/html)
2004-08-15 03:54 PDT, bht237
no flags Details

Description bht237 2004-08-15 03:53:49 PDT
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.1) Gecko/20040707


The attached testcase shows an error "Error: uncaught exception: Permission
denied to get property Window.getBody" in the JavaScript console.

I really don't know what to think and I don't have a sound workaround strategy
because I cannot explain the behavior.

The code is fairly defensive - all is based on the frameset onLoad event and
even a SetTimeout is used as not to hit another bug.

No problems with Netscape 4, IE.
Comment 1 bht237 2004-08-15 03:54:56 PDT
Created attachment 156142 [details]
Testcase
Comment 2 Doug Wright 2004-08-15 07:06:17 PDT
WFM after a reload - but I see described behaviour on initial viewing with

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040810
Firefox/0.9.1+
Comment 3 Serge Gautherie (:sgautherie) 2008-05-12 07:42:36 PDT
MozillaAS v1.7.x is not supported anymore.

Can you reproduce with SeaMonkey v1.1.9 ?
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2010-10-28 09:18:20 PDT
The attached testcase worksforme.

Note You need to log in before you can comment on or make changes to this bug.