If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Does not support AppleScript command 'doJavaScript'

RESOLVED DUPLICATE of bug 5704

Status

()

Core
JavaScript Engine
--
enhancement
RESOLVED DUPLICATE of bug 5704
13 years ago
13 years ago

People

(Reporter: David Atherton, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.2) Gecko/20040803

This applies to Mozilla, Firefox 0.9.3 and Camino 0.8b+. I use Web Confidential
3.7.5 to store passwords. Safari and IE support the AppleScript command
'doJavaScript' allowing me to enter IDs and passwords directly from a drop-down
menu within the browsers. This does not work in your three browsers.  I choose
the appropriate item from the Shared Menu at the top of the screen, but on
clicking on ID & password I'm presented with a new page and a URL of 

Javascript:function xsetuseridandpwd(j) { 

With IE and Safari the ID & password are accepted and take me to the correct page.

Please take a look at

http://www.apple.com/applescript/safari/jscript.01.html

This gives the functional specification of what is needed.

The developer of Web Confidential is extremely responsive: alco.blom@mac.com

For a long time I have wanted to switch from Safari (and definitely from IE),
but the inability to use the Shared Menus of Web Confidential has held me back.

Keep up the brilliant work. 
David Atherton 

Reproducible: Always
Steps to Reproduce:

Comment 1

13 years ago
Please search for duplicates before filing bugs, thanks.

*** This bug has been marked as a duplicate of 5704 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.