The was an error starting ChatZilla. message (string) 'this.docShell has no properties'

RESOLVED FIXED

Status

Other Applications
ChatZilla
--
minor
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: timeless, Assigned: James Ross)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a3) Gecko/20040815

The was an error starting ChatZilla. Please report the following information:
+ message (string) 'this.docShell has no properties'
+ fileName (string) 'chrome://global/content/bindings/browser.xml'
+ lineNumber (number) 0
+ stack (string) 381 chars
+ name (string) 'TypeError'
*

steps:
1. load about:config
2. toggle browser.frames.enabled
3. quit
4. run mozilla
5. cmd-6
6. read dialog
7. smile
8-20. try and figure out how to copy the error message from the dialog since
domi and navigator don't work. venkman barely did, so eventually i saved the
messageText as a preference, restored frames.enabled and ran navigator to
about:config.
(Assignee)

Comment 1

14 years ago
The dialog /would/ have been a big copyable-editbox if I could do it without
adding more that could fail. :)  (though I'll give it a go)
(Reporter)

Comment 2

14 years ago
use .prompt :)
(Assignee)

Comment 3

14 years ago
(In reply to comment #2)
> use .prompt :)

Too simple. ;)  I've got a dialog created from a data: URL that sets some
content up from an onload in the dialog itself... because the XUL parser is
unfriendly. It looks good, and lets you select/copy the text.
Product: Core → Other Applications
(Assignee)

Comment 4

14 years ago
I tried this with Firefox (yeah, yeah).

Step 4 was a problem. Firefox will not run with that preference change. :)

Oh well, I'll have to try Mozilla later...

Comment 5

13 years ago
WFM on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050307
with Chatzilla 0.9.67 [Mozilla rv:1.8b2/20050307]

WFM on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050311
Firefox/1.0+ with Chatzilla 0.9.67a [Firefox 1.0+/20050311]

(Note that the 'a' CZ was built by me to make up for the lack of nightlies now
that Silver is temporarily gone. It should be exactly the same as the 0.9.67
version used on the Seamonkey nightly build)

Timeless (or anyone else for that matter), can you still reproduce this bug?

Comment 6

13 years ago
Marking FIXED, it seems this was fixed by the checkin for bug 240129, so it's
fixed in current CVS.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.