Pseudo Class :active should not apply to any element

RESOLVED DUPLICATE of bug 243459

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 243459
13 years ago
13 years ago

People

(Reporter: Lachlan Hunt, Assigned: dbaron)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

The :active pseudo class should not apply to any element, it should only apply
to elements that are defined in the (X)HTML, or other XML language specs as
being able to be activated.  So, basically hyperlinks (a with href), buttons,
etc. should apply the :active state when clicked.  As a general guide, :active
should apply to those elements that can also recieve :focus.

More tests are available for HTML (HTML 4.01), XHTML and XML (XHTML1.1).  See
the pseudo-class-active-* files here:
http://www.lachy.id.au/dev/css/tests/css21/5-selectors/

Reproducible: Always
Steps to Reproduce:
1. Go to the test cases
2. Click on the green text
Actual Results:  
:active is applied to the elements, but it shouldn't.

Expected Results:  
The text should stay green.
(Assignee)

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Updated

13 years ago
Assignee: nobody → dbaron
Component: Layout: Misc Code → Style System (CSS)
QA Contact: core.layout.misc-code → ian

*** This bug has been marked as a duplicate of 243459 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.