HTTP Content-Type should not override meta http-equiv="Content-Type" value

RESOLVED DUPLICATE of bug 214952

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 214952
14 years ago
13 years ago

People

(Reporter: Eyal Rozenberg, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040714
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040714

I connect to a webserver, send

GET /test/b.html HTTP/1.0

and get a response with 

Content-Type: text/html; charset=iso-8859-1

in the HTTP headers but a

<meta http-equiv="Content-Language" content="he">
<meta http-equiv="Content-Type" content="Text/html; charset=windows-1255">

on the page itself. Both Mozilla (and MSIE BTW) display this page with
ISO-8859-1, not windows-1255 . Why? Surely the web page knows better than the
web server (which usually doesn't keep an charset value for each of the pages it
serves) what its own charset is...

I am 99% sure this bug is a dupe, but I can't only seem to find related bugs,
not an identical one. Bug 237537 is related but it seems that bug is for cases
where (supposedly) no Content-Type is sent by the server.

PS - don't tell me to fix the web server, suppose it is not under my control.


Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
The server setting always gets precedence over the meta tag.

*** This bug has been marked as a duplicate of 214952 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.