Pages without host show "Allow popups for" in info bar menu

RESOLVED DUPLICATE of bug 204285

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 204285
14 years ago
5 years ago

People

(Reporter: Blake Ross, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

14 years ago
Steps to Reproduce:

1. Save a website that opens a popup to your hard drive.
2. Load the local version in Firefox.
3. Click on the info bar to show the dropdown menu.

Actual result: Sloppy "Allow popups for" menuitem (with nothing after "for")

Expected result: ?? Probably just hide this menuitem.
Assignee: bugs → nobody

Comment 1

10 years ago
Pages without hosts are most likely file:// based URLs.

In that situation, I think a message like "Allow popups for local files" would be more appropriate.

Related issue: in the popup blocker whitelist dialog, file:// URLs appear as "scheme:file". "Local files" here would also be better I think.

Comment 2

10 years ago
Created attachment 283412 [details] [diff] [review]
v1

based on the proposal from comment 1. I used "local files" for the label, while Firebug uses "Local Files", I'm not sure what's the best use here.
Assignee: nobody → sylvain.pasche
Status: NEW → ASSIGNED
Attachment #283412 - Flags: review?(gavin.sharp)
Where does "scheme:file"? Does that value being on the whitelist actually allow all file:// URIs to open popups?

Comment 4

10 years ago
(In reply to comment #3)
> Where does "scheme:file"? Does that value being on the whitelist actually allow
> all file:// URIs to open popups?

yes, scheme:file is used in the whitelist for unblocking all file:// URIs:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/extensions/cookie/nsPermissionManager.cpp&rev=1.63&mark=1011-1020#1011

The label "scheme:file" will appear in the pop-up whitelist dialog if you allow popups for a file:/// document.
using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008071803

- it still states 'Allow pop-ups for'
- you can *not* add a local pop-up-generating site to the whitelist (anymore) like states above

so what is the status of the to be reviewed and almost forgotten patch here?
Version: unspecified → Trunk

Comment 6

10 years ago
that patch won't work because of bug 204285 (which is the regression you describe).
Assignee: sylvain.pasche → nobody
Status: ASSIGNED → NEW
Depends on: 204285
OS: Windows XP → All
Hardware: PC → All

Updated

10 years ago
Attachment #283412 - Attachment is obsolete: true
Attachment #283412 - Flags: review?(gavin.sharp)

Comment 7

7 years ago
This is a duplicate of Bug 204285
Indeed, it is a duplicate of bug 204285 which is very likely fixed in trunk.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 204285
You need to log in before you can comment on or make changes to this bug.