If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status icon calls all newsfeeds RSS (even Atom)

RESOLVED FIXED

Status

()

Firefox
Toolbars and Customization
--
trivial
RESOLVED FIXED
13 years ago
11 years ago

People

(Reporter: gkn, Assigned: Kevin Gerich)

Tracking

({fixed-aviary1.0})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.2) Gecko/20040818 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.2) Gecko/20040818 Firefox/0.9.1+

The new status icon, which appears when a newsfeed is linked to from the current
page, says "RSS" even when the newsfeed is not RSS (e.g. when it's Atom). This
may confuse people into thinking Atom is a kind of RSS, which it isn't.

Other UI uses the format-neutral term "feed" which is both more correct and more
descriptive, although less buzzword-y.

(btw I do understand that you're caught between the rock of pedantic gits like
me and the hard place of the uneducated hoi polloi.)

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
http://diveintomark.org/ is one example where this happens.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

13 years ago
OS: Windows XP → All
Hardware: PC → All
I brought this up in Kevin Gerich's weblog post about the new images when they
were added.  Kevin responded by saying that RSS has almost become a generic
term, and he cited Safari RSS (Apple is making it generic, too) as at least
supporting evidence.  The arguments are more fully elucidated there, so consider
them before doing anything about this bug.  Look near the end of comments for
the exchange of thoughts.

http://kmgerich.com/archive/000068.html
I agree with Kevin -- RSS is these days used as a generic term.  RSS by itself
doesn't mean anything specific even -- there are 3 distinct types of "RSS" out
there, not all that compatible with eachother.  Atom just ends up being a
fourth; end users don't care what format their "RSS" is in.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Comment 4

13 years ago
There are 9 incompatible versions of RSS[1], actually. And you can make 11
different types of feeds validate.

Atom is most certainly not RSS and shouldn't be called that way. "Feed", as
suggested in comment 0 is a much more neutral and better term.


[1]<http://diveintomark.org/archives/2004/02/04/incompatible-rss>
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Comment 5

13 years ago
(In reply to comment #3)
> I agree with Kevin -- RSS is these days used as a generic term.  RSS by itself
> doesn't mean anything specific even -- there are 3 distinct types of "RSS" out
> there, not all that compatible with eachother.  Atom just ends up being a
> fourth; end users don't care what format their "RSS" is in.

Thinking about it again:

"RSS" stands for "Rich Site Summary"; the Atom format is primarily used to
syndicate a selection of a website's contents along with appropriate metadata.
Sounds like a "rich site summary" to me.

If one considers "RSS" as a type of content - literally a "rich site summary" -
rather than a format, it seems suitable to describe an Atom feed as an RSS.
Users shouldn't have to care what format a rich site summary is written in.

An Atom 0.3 feed looks as much like an RSS 1.0 feed as does an RSS 2.0 feed -
there is no format which can be defined as "RSS".

The bug is that "RSS" is not format-neutral, but I now believe that "RSS" isn't
a format; so, I'm exercising my ill-gotten power as the reporter of the bug and
resolving it as invalid.

On the other hand, it would be nice to use the term "Atom Site Summary" and
introduce a large "ASS" icon in Firefox's status bar.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID

Comment 6

13 years ago
RSS also stands for Really Simple Syndication and RDF Site Summary. It is a
bogus abbreviation (note that Atom isn't an abbreviation at all).

I think the people who make these descisions don't know half about the history
of RSS and therefore make the wrong conclusions.
(Reporter)

Comment 7

13 years ago
(In reply to comment #6)
> RSS also stands for Really Simple Syndication and RDF Site Summary. It is a
> bogus abbreviation (note that Atom isn't an abbreviation at all).
> 
RSS 2.0 isn't RDF, so RSS isn't (always) used as meaning RDF Site Summary. Atom
is also a really simple way of syndicating content.

> I think the people who make these descisions don't know half about the history
> of RSS and therefore make the wrong conclusions.

Didn't Netscape invent RSS?

Comment 8

13 years ago
> RSS 2.0 isn't RDF, so RSS isn't (always) used as meaning RDF Site Summary.
> Atom is also a really simple way of syndicating content.

Exactly my point, people don't know half of it. RSS 2.0 is a underspecified
specification. RSS 1.0 is based on RDF, just look at the /news.rdf on the
mozilla.org homepage.

Atom requires a lot more and can't be called really simple syndication.
Something that requires at least two dates specified according to some iso
specification I can't recall at the moment, a universally unique ID based on a
URI that should be interpretid as a string etc.

> Didn't Netscape invent RSS?

I this a joke? Of course Netscape invented RSS. It is about what happend after
that, with Userland etc...
(Reporter)

Comment 9

13 years ago
(In reply to comment #8)
> > RSS 2.0 isn't RDF, so RSS isn't (always) used as meaning RDF Site Summary.
> > Atom is also a really simple way of syndicating content.
> 
> Exactly my point, people don't know half of it.

They shouldn't have to.

> RSS 2.0 is a underspecified
> specification. RSS 1.0 is based on RDF, just look at the /news.rdf on the
> mozilla.org homepage.
> 
> Atom requires a lot more and can't be called really simple syndication.
> Something that requires at least two dates specified according to some iso
> specification I can't recall at the moment, a universally unique ID based on a
> URI that should be interpretid as a string etc.

It's still pretty simple. The date format to use is 2004-09-21T19:18Z, which is
simpler than Tue, 21 Sep 2004 19:18:00 GMT, especially for non-anglophones. I
find Atom to be simpler than RSS 1.0.

> 
> > Didn't Netscape invent RSS?
> 
> I this a joke? Of course Netscape invented RSS. It is about what happend after
> that, with Userland etc...

...because of which, "RSS" ceased to be a format and became the generic name for
a type of content.

Comment 10

13 years ago
Atom is well specified and I very much like it therefore. RSS 2.0 is easy, but
awful because it isn't well specified. RDF is just damn complex. RSS is a bogus
abbreviation because it has 3 meanings, you could ask Google for them using
define:RSS.

I'm just saying that the status icon should be called 'feed' or some other more
generic term.

I think that people who are implementing this stuff should now the history
because RSS has a lot of incompatibilities and troubles like non-normative,
contradicting specifications etc.

Comment 11

13 years ago
Why are we even discussing RSS versions?

The thing here is that the text on the icon is 'RSS' which works well for any
RSS version.

But firefox also supports Atom, and 'RSS' is not a good way to describe that, so
the more generic term 'Feed' should be used instead.

Comment 12

13 years ago
Or, ideally, it would be a symbol rather than a bunch of random letters.
Kevin Gerich has created a nifty one that I think should be checked in for 1.0.
(Reporter)

Comment 13

13 years ago
(In reply to comment #12)
> Or, ideally, it would be a symbol rather than a bunch of random letters.
> Kevin Gerich has created a nifty one that I think should be checked in for 1.0.

Link, please :)
(Assignee)

Comment 14

13 years ago
I'm reopening this one, because Stephen just checked in a new Live Bookmark
status and folder icon. Marking fixed-aviary1.0

My comment about RSS being a generic term is really beside the point. The icon
should represent the live bookmark feature, not the technology powering it.  
Status: RESOLVED → REOPENED
Keywords: fixed-aviary1.0
Resolution: INVALID → ---
(Assignee)

Comment 15

13 years ago
I'm reopening this one, because Stephen just checked in a new Live Bookmark
status and folder icon. Marking fixed-aviary1.0

My comment about RSS being a generic term is really beside the point. The icon
should represent the live bookmark feature, not the technology powering it.  
(Assignee)

Comment 16

13 years ago
Created attachment 160150 [details]
Picture of the new Live Bookmark status bar icon
Assignee: bugs → webmail
Status: REOPENED → ASSIGNED
(Reporter)

Comment 17

13 years ago
The new icon looks very nice in today's nightly. However, live bookmarks still
appear as yellow folders in the bookmarks manager; is there a bug number for this?
I noticed that linux and mac still use the "RSS" icon (instead of the one in
attachment 160150 [details]) --does this bug track that, or is there another one filed for
that?
(Assignee)

Comment 19

13 years ago
checked in the Pinstripe version on the branch
The status bar icon looks good on Mac branch build 2004-10-04-06-0.9  The icon
is now the broadcast signal icon.

Are livemarks supposed to have a folder icon that is different from a regular
bookmark folder?  The current Mac build does not have a livemark folder icon
that is different from other folder icons.  That should be a different bug, but
according to comment 15 it was already checked in.

Comment 21

13 years ago
Has the icon been reverted to the RSS icon again the latest builds, if so why?
(Assignee)

Comment 22

13 years ago
Nope.

Comment 23

13 years ago
The new status icon has only made its way into a few themes so far. If you're
not using the default theme, you're likely to still see the "RSS" icon.

Comment 24

13 years ago
Yes, I had some old files .. I see the right icon now. Since the RSS icon isn't
used anymore maybe this bug should be closed?
(Assignee)

Comment 25

13 years ago
This has been fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.