variable width images not displayed correctly

VERIFIED DUPLICATE of bug 39901

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 39901
19 years ago
18 years ago

People

(Reporter: Deleted User, Assigned: clayton)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

19 years ago
M13 used. Code snippet below:

<HTML>
<HEAD>
<TITLE>Test</TITLE>
</HEAD>
<BODY>
<TABLE BORDER="0" WIDTH="100%">
<tr>
<td width="50%">
<img src="/images/lib/blackdot.gif" width="100%" height="2">
</td>
<td nowrap>This is some text</td>
<td width="50%">
<img src="/images/lib/blackdot.gif" width="100%" height="2">
</td>
</tr>
</table>
</body>
</html>

blackdot.gif is a single pixel black dot :)

Expected result: a black line across the screen, broken in the middle by the
text.

Actual result: the two images are a single px width, so show only as
left-aligned dots on the page.

This is behaviour seen in other examples too.

Comment 1

19 years ago
This seems to work fine with the latest build. I guess one of the many changes 
between M13 and the current builds must have fixed it
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Updated

19 years ago
Keywords: verifyme

Comment 2

18 years ago
Created attachment 11273 [details]
Picture of problem on 2000071108

Comment 3

18 years ago
Created attachment 11274 [details]
Enclosed package of Graphic and html.  This all fits into one source directory.

Comment 4

18 years ago
Reopening bug.  Screenshots are from 2000071108 on Linux.  Also confirmed on
2000071112 on Win 98.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 5

18 years ago
Created attachment 11541 [details]
Demonstration of resizing cases... (Enlargement)

Comment 6

18 years ago
Created attachment 11542 [details]
Demonstration of Resizing

Comment 7

18 years ago
<a 
href="http://www.ics.olemiss.edu/mozilla/mozilla_resize.php">mozilla_resize.php<
/a>
Gives some test cases and shows some interesting aspect.

On Linux Build 2000071810 and Win32 Build 2000071708
Proportional height increase without a width determines proportional resize. 
Proportional width increase without a height has no effect
Proportional height increase with specific width works correctly
Proportional width increase with specific height has no effect

All decreases in size are all proportional regardles... ???

Strikes me odd...

Comment 8

18 years ago
Created attachment 12434 [details]
Testcase2

Comment 9

18 years ago
Attached "Testcase2", which shows bug without involving tables.
Adding keyword "testcase" and reassigning to owner of Layout.
Assignee: troy → clayton
Status: REOPENED → NEW
Keywords: verifyme → testcase
OS: Linux → All

*** This bug has been marked as a duplicate of 39901 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 11

18 years ago
verified dup. I hate duping forward but there's been more activity on 39901...
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.