Firefox 0.9.3 crash [@ 0x11d010 - ole32.dll] on XP x64 Edition (AMD64) Preview release 2 with DEP

RESOLVED DUPLICATE of bug 233765

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 233765
13 years ago
7 years ago

People

(Reporter: u49640, Unassigned)

Tracking

({64bit, crash})

1.0 Branch
x86
Windows XP
64bit, crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

When i start Firefox 0.9.3 on my Athlon64 with Win XP Pro x64 Preview Release 2
(thats the version for AMD64 CPUs) it crashed when i had DEP enabled. After
disabling DEP it works fine

Reproducible: Always
Steps to Reproduce:
1. Start Firefox 0.9.3 on XP 64Bit Edition with DEP enabled




Talkback id: TB601925G

The Windows Version is: Version 5.2.3790
Build 3790.dnsrv_idx01.040726-1300 : Service Pack 1, v. 1218)

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 233765 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
no thats not the same bug, Firefox runs absolutely fine here with XP SP2 and DEP
activated. it just crashes with the true 64 Bit Version of windows.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

13 years ago
Confirming based on talkback data, plenty of it.

Looking at the talkbacks, this is a seperate and 64bit OS-dependent crash.
Talkback list
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=ole32.dll+%2B+0x11d010&vendor=All&product=All&platform=All&buildid=&sdate=&stime=&edate=&etime=

All the XP SP2 talkbacks point to msvcrt.dll, all the XP 64bit point to ole32.dll
(Correct me if I did the changes wrong)
Blocks: 237202
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: 64bit, crash
Summary: Firefox 0.9.3 wont start on XP x64 Edition (AMD64) Preview release 2 if DEP is enabled → Firefox 0.9.3 crash [@ 0x11d010 - ole32.dll] on XP x64 Edition (AMD64) Preview release 2 with DEP

Comment 4

13 years ago
Whether or not this is considered a duplicate of
http://bugzilla.mozilla.org/show_bug.cgi?id=233765, doing a custom install and
ommiting the talkback option also works with Win XP Pro x64 and is a better
workaround than disabling DEP.

Comment 5

12 years ago
anyone know if this problem still exists using latest builds and OS updates?
(Reporter)

Comment 6

12 years ago
(i'm the reporter)

i dont have XP 64 installed anymore, so i cant test it
Assignee: bross2 → nobody
Version: unspecified → 1.0 Branch

Comment 7

10 years ago
Incident ID: 41466353
Stack Signature	ole32.dll + 0x11d010 (0x776ad010) 0c1b5e99
Product ID	Firefox10
Build ID	2004100109
Trigger Time	2008-02-14 13:50:40.0
Platform	Win32
Operating System	Windows NT 5.2 build 3790
Module	ole32.dll + (0011d010)
URL visited	
User Comments	
Since Last Crash	0 sec
Total Uptime	2 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
ole32.dll + 0x11d010 (0x776ad010)
nsWindow::EnableDragDrop  [mozilla/widget/src/windows/nsWindow.cpp, line 2887]
DocumentViewerImpl::MakeWindow  [mozilla/content/base/src/nsDocumentViewer.cpp, line 1958]
DocumentViewerImpl::InitInternal  [mozilla/content/base/src/nsDocumentViewer.cpp, line 836]
DocumentViewerImpl::Init  [mozilla/content/base/src/nsDocumentViewer.cpp, line 639]
nsDocShell::Embed  [mozilla/docshell/base/nsDocShell.cpp, line 4191]
nsDocShell::CreateAboutBlankContentViewer  [mozilla/docshell/base/nsDocShell.cpp, line 4505]
nsDocShell::EnsureContentViewer  [mozilla/docshell/base/nsDocShell.cpp, line 4434]
nsWebShell::GetInterface  [mozilla/docshell/base/nsWebShell.cpp, line 313]
nsGetInterface::operator()  [mozilla/xpcom/glue/nsIInterfaceRequestorUtils.cpp, line 53]
nsCOMPtr_base::assign_from_helper  [mozilla/xpcom/glue/nsCOMPtr.cpp, line 114]
GlobalWindowImpl::GetDocument  [mozilla/dom/src/base/nsGlobalWindow.cpp, line 1076]
nsWindowWatcher::URIfromURL  [mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp, line 1128]
nsWindowWatcher::OpenWindowJS  [mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp, line 497]
nsWindowWatcher::OpenWindow  [mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp, line 458]
XPTC_InvokeByIndex  [mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp, line 102]
XPCWrappedNative::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2028]
XPC_WN_CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 1287]
js_Invoke  [mozilla/js/src/jsinterp.c, line 941]
js_Interpret  [mozilla/js/src/jsinterp.c, line 2973]
js_Invoke  [mozilla/js/src/jsinterp.c, line 958]
nsXPCWrappedJSClass::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 1336]
nsXPCWrappedJS::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 450]
SharedStub  [mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp, line 147]
xre_main  [mozilla/toolkit/xre/nsAppRunner.cpp, line 1845]
main  [mozilla/browser/app/nsBrowserApp.cpp, line 58]
kernel32.dll + 0x20943 (0x77e60943)
This is talkback issue.  dup of bug 233765.

Also, this doesn't occurs on BreakPad
Status: NEW → RESOLVED
Last Resolved: 13 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 233765
(Assignee)

Updated

7 years ago
Crash Signature: [@ 0x11d010 - ole32.dll]
You need to log in before you can comment on or make changes to this bug.