Closed Bug 256251 Opened 17 years ago Closed 5 years ago

ommni.com - Can't log in

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: raoul, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040803

This is because of a stupid JavaScript code at
http://www.ommni.com/top_nav_home.asp?guid=line
in line 87-89 (of resulting HTML code)
<a href="#" onClick="javascript:submit(loginid,pwd);">
<img src="images/loginHomePage.gif" width="29" height="15" border="0"/>
</a> 

Webmaster should replace it for:
<input type="image" src="images/loginHomePage.gif" alt="Login"
      width="29" height="15" border="0" />

and all will be OK.

Reproducible: Always
Steps to Reproduce:
Summary: Can't log in → ommni.com - Can't log in
Error: submit is not defined
Source File: https://www.ommni.com/top_nav_home.asp?guid=
Line: 1

Confirming. Raoul, can you please contact them and point them to this bug, explaining why this is broken in non-IE browsers?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
This site has launched an updated version at CNACargo.com , where there is no such issue.

It is however still a problem on their old site, and some of their customers may still be required to access the old version. Site says about the "omni.com" old version link:

 	- All Clients reporting shipments on 2007 policy terms and prior please click here
	- All Clients based in Continental Europe please click here

In particular, the second point causes some concern..
I'll keep this open with a slightly lower priority since the issue hopefully affects few users now.
Severity: normal → minor
Assignee: english-us → nobody
Component: English US → Desktop
I don't think this issue with be fixed.

https://www.ssllabs.com/ssltest/analyze.html?d=www.ommni.com&latest
Their SSL certificate has expired __two years ago__
It also has a weak signature with a grade B.

I'm closing this as WONTFIX as the site doesn't seem to be maintained at all.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.