IMAP delete of folder doesn't move folder to Trash.

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
14 years ago
10 years ago

People

(Reporter: stephend, Assigned: Bienvenu)

Tracking

({fixed-aviary1.0, regression})

Trunk
x86
Windows XP
fixed-aviary1.0, regression
Bug Flags:
blocking-aviary1.0PR +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

14 years ago
Build ID: 2004-08-20-07, Windows XP, Seamonkey Trunk.

Summary: IMAP delete of folder doesn't move folder to Trash.

Steps to Reproduce:

1.  Create a folder "DeleteMe" as a sibling under Inbox (I'm on Cyrus)
2.  Delete it using the context menu

Actual Results:

"Unsubscribing from folder INBOX.DeleteMe..." appears in the window.status area

Expected Results:

Folder is moved visually to the subfolder of INBOX.trash

I just tested this in 1.7 (Netscape 7.2) and it works fine with this server.

Log to follow.
(Reporter)

Comment 1

14 years ago
Created attachment 156626 [details]
Logfile
(Reporter)

Comment 2

14 years ago
Created attachment 156627 [details]
Screenshot; this is all I see until I restart.
(Reporter)

Updated

14 years ago
Flags: blocking1.8a4?
(Assignee)

Comment 3

14 years ago
Stephen, do you have empty trash on exit set?
(Reporter)

Comment 4

14 years ago
(In reply to comment #3)
> Stephen, do you have empty trash on exit set?

Yes, yes I do.  Want me to try it without and get a log for that?
(Assignee)

Comment 5

14 years ago
yes, I believe we're deleting the folder from the trash when you exit, instead
of just the messages in the trash folder.  That explains why the folder doesn't
appear as a sub-folder of the trash when you restart, at least.
(Reporter)

Comment 6

14 years ago
With 'Empty trash on exit' OFF...

Launch (Inbox loads by default, no messages selected)
Create folder DeleteMe via context menu
Select DeleteMe (contains no messages)
Delete (context menu)
File | Empty Trash
Exit

I still see the same behavior -- until I restart, the folder is visible in the
Folder Pane's tree view, but when selected, alerts me that the folder does not
exist.

And according to this snippet from the logfile, the delete/unsubscribe of the
folder "DeleteMe" actually works, but we're failing to notify the front end,
somehow.

calls)412[213ed90]: 216a4a0:imap.indiana.edu:S-INBOX.Trash:SendData: 6 delete
"INBOX.Trash.DeleteMe"412[213ed90]: ReadNextLine [stream=216b640 nb=16 needmore=0]
412[213ed90]: 216a4a0:imap.indiana.edu:S-INBOX.Trash:CreateNewLineFromSocket: 6
OK Completed412[213ed90]: 216a4a0:imap.indiana.edu:S-INBOX.Trash:SendData: 7
unsubscribe "INBOX.Trash.DeleteMe"412[213ed90]: ReadNextLine [stream=216b640
nb=16 needmore=0]
412[213ed90]: 216a4a0:imap.indiana.edu:S-INBOX.Trash:CreateNewLineFromSocket: 7
OK Completed412[213ed90]: 216a4a0:imap.indiana.edu:S-INBOX.Trash:SendData: 8
IDLE412[213ed90]: ReadNextLine [stream=216b640 nb=12 needmore=0]
412[213ed90]: 216a4a0:imap.indiana.edu:S-INBOX.Trash:CreateNewLineFromSocket: +
go ahead2848[20107e0]: 20121e8:imap.indiana.edu:S-INBOX:SendData:
DONE2848[20107e0]: ReadNextLine [stream=2015c70 nb=17 needmore=0]
2848[20107e0]: 20121e8:imap.indiana.edu:S-INBOX:CreateNewLineFromSocket: 17 OK
Completed2848[20107e0]: 
(Reporter)

Comment 7

14 years ago
Created attachment 158133 [details]
Logfile with Empty Trash on Exit off.
(Assignee)

Comment 8

14 years ago
yup, I see this happening as well.
Status: NEW → ASSIGNED

Comment 9

14 years ago
David's going to try to fix this for tbird 0.8. 
Flags: blocking-aviary1.0PR+
(Assignee)

Comment 10

14 years ago
Created attachment 158366 [details] [diff] [review]
proposed fix

make OpenMailDBFromFileSpec return success if the caller says to create a db if
one is missing. This is only called from a couple places, and I've tested that
the existing callers are fine with the change.
(Assignee)

Updated

14 years ago
Attachment #158366 - Flags: superreview?(mscott)

Updated

14 years ago
Attachment #158366 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 11

14 years ago
fixed on trunk and branch, thx, Stephen.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
(Reporter)

Updated

14 years ago
QA Contact: grylchan → stephend
(Assignee)

Comment 12

14 years ago
*** Bug 258338 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 13

14 years ago
Verified FIXED on today's 2004-09-09-16 Seamonkey trunk build on Windows XP.

Thanks David!
Status: RESOLVED → VERIFIED
(Reporter)

Updated

14 years ago
Flags: blocking1.8a4?
(Reporter)

Comment 14

14 years ago
The build date ID is wrong on today's build, but the bug is indeed fixed (sorry
for the spam!)
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.