Bug 256514 (xsltlinks)

Links don't work in documents created via XSLT

VERIFIED FIXED

Status

()

Core
XSLT
--
major
VERIFIED FIXED
13 years ago
12 years ago

People

(Reporter: Doug Wright, Assigned: peterv)

Tracking

({fixed-aviary1.0, fixed1.7, regression})

Trunk
x86
Windows XP
fixed-aviary1.0, fixed1.7, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040820 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040820 Firefox/0.9.1+

Quick example is Dean Edward's page getting XHTML documents to display in IE. A
completely different example is http://www.dougsdvds.info/list/test.xml. 

This WORKS in 1.7.2
This WORKS in 1.7.3(20040822 nightly)
This DOESN'T WORK in Firefox 0.9.1+ (20040820 nightly)

I've filed it here, because there doesn't seem to be an appropriate section
under the Firefox heading

Reproducible: Always
Steps to Reproduce:
1. Load a document created via XSLT
2. Try and click a link


Actual Results:  
Page didn't change, status bar didn't show target

Expected Results:  
Followed the link
(Reporter)

Comment 1

13 years ago
Forgot to mention - it worked in Firefox builds around 20040725 (roughly - maybe
a week before), cos that's when I created the 2nd page mentioned above. I can't
narrow it down any further I'm afraid.
A smaller testcase would be nice. And please attach it to the bug rather then
just point to a url. URLs tend to go away after a while.
(Reporter)

Comment 3

13 years ago
Created attachment 156772 [details]
XSL stylesheet
(Reporter)

Comment 4

13 years ago
Created attachment 156774 [details]
XML
(Reporter)

Comment 5

13 years ago
View the 2nd attachment to see the problem.
(Assignee)

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

13 years ago
Odd stuff happening.
Middle click opens the link in a new tab, context menu works as well. Just
single click doesn't work. My debug aviary doesn't complain about anything, though.
This sounds pretty bad and a major regression. It would be pretty useless to
ship xslt support with this.
Flags: blocking-aviary1.0?
(Reporter)

Comment 8

13 years ago
I've tested various nightly builds, and have managed to establish that this
regressed between the 17th and the 19th. The build for the 18th crashes on
startup, so I can't test that.

The list of checkins between those builds is at http://tinyurl.com/3s9tj

This is as far as my skills take me I'm afraid.
Maybe the fix for bug 198254?

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/layout/html/base/src&command=DIFF_FRAMESET&file=nsPresShell.cpp&rev1=3.712.2.2.2.3&rev2=3.712.2.2.2.4&root=/cvsroot

Comment 10

13 years ago
(In reply to comment #9)
> Maybe the fix for bug 198254?
> 
>
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/layout/html/base/src&command=DIFF_FRAMESET&file=nsPresShell.cpp&rev1=3.712.2.2.2.3&rev2=3.712.2.2.2.4&root=/cvsroot

backed out locally and it works on yesterdays aviary.
(Assignee)

Comment 11

13 years ago
Created attachment 156890 [details] [diff] [review]
v1
(Assignee)

Updated

13 years ago
Attachment #156890 - Flags: superreview?(jst)
Attachment #156890 - Flags: review?(jst)
Comment on attachment 156890 [details] [diff] [review]
v1

r+sr=jst
Attachment #156890 - Flags: superreview?(jst)
Attachment #156890 - Flags: superreview+
Attachment #156890 - Flags: review?(jst)
Attachment #156890 - Flags: review+

Updated

13 years ago
Keywords: regression
Comment on attachment 156890 [details] [diff] [review]
v1

This is a regression from a change that went in on both the aviary and 1.7
branches. We should take this regression fix on both branches IMO.
Attachment #156890 - Flags: approval1.7.3?
Attachment #156890 - Flags: approval-aviary?

Comment 14

13 years ago
Comment on attachment 156890 [details] [diff] [review]
v1

a=mkaply
Attachment #156890 - Flags: approval1.7.3?
Attachment #156890 - Flags: approval1.7.3+
Attachment #156890 - Flags: approval-aviary?
Attachment #156890 - Flags: approval-aviary+
Fix landed on the aviary and 1.7 brances.
Keywords: fixed-aviary1.0, fixed1.7
(Assignee)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Updated

13 years ago
Flags: blocking-aviary1.0?
(Reporter)

Updated

13 years ago
Status: RESOLVED → VERIFIED
Alias: xsltlinks
*** Bug 257295 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.