right click menus not working

VERIFIED FIXED

Status

()

Core
DOM: Events
--
major
VERIFIED FIXED
14 years ago
13 years ago

People

(Reporter: Stef van der Made, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
In mozilla nightly build 20040823 in the mail application I can not open a menu
by right clicking with the mouse. 

Expected results

1 Open link in new tab or window on clicking on a link
2 On text copy paste etc etc

actual result no menu shows in mail and news
Severity: normal → major
Flags: blocking1.8a4?
Keywords: regression
OS: Linux → All
Hardware: PC → All
Summary: right click menus now working → right click menus not working
(Assignee)

Comment 1

14 years ago
The chrome event handler for whatever reason needs to fix context menu events.
If the event already has a DOM event (perhaps it got retargetted during the
capturing phase, because it was dispatched to a tabbrowser), then all passes off
well and good. However, for explicit browser elements, no such event exists.
Unfortunately the event listener manager then creates a DOM UI event :-(
Component: Mail Window Front End → DOM: Events
Product: MailNews → Browser
(Assignee)

Comment 2

14 years ago
Created attachment 156843 [details] [diff] [review]
Proposed patch
Assignee: sspitzer → neil.parkwaycc.co.uk
Status: NEW → ASSIGNED
(Assignee)

Updated

14 years ago
Attachment #156843 - Flags: superreview?(jst)
Attachment #156843 - Flags: review?(bryner)
Comment on attachment 156843 [details] [diff] [review]
Proposed patch

sr=jst
Attachment #156843 - Flags: superreview?(jst) → superreview+
*** Bug 256780 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

14 years ago
Mayby a stupid question but when will the patch be included in the nightly build
? As the patch looks to be included in CVS.

Comment 6

14 years ago
*** Bug 256893 has been marked as a duplicate of this bug. ***
*** Bug 256892 has been marked as a duplicate of this bug. ***
Attachment #156843 - Flags: review?(bryner) → review+
(Assignee)

Comment 8

14 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

14 years ago
Problem verified as solved on build 20040826

Thanks

Comment 10

14 years ago
*** Bug 256924 has been marked as a duplicate of this bug. ***
Verified 20040826 on WinXP.
Status: RESOLVED → VERIFIED
Flags: blocking1.8a4?

Comment 12

13 years ago
*** Bug 256916 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.