bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

MSIE must be installed for Mozilla installation to succeed

RESOLVED WORKSFORME

Status

SeaMonkey
Installer
--
major
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Marc Mongenet, Unassigned)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a3) Gecko/20040817
Build Identifier: mozilla-win32-1.7.2-installer.exe

I get the following message when trying to install
mozilla-win32-1.7.2-installer.exe on a freshly installed Windows 95:

1157 : Could not load C:\WINDOWS\TEMP\ns_temp\xpcom.ns\bin\xpistub.dll

This is the first release of Windows 95, the one without MSIE. The only other
installed application is WinRAR.

Reproducible: Always
Steps to Reproduce:

Actual Results:  
The installation fails with only a few dirs and two log files 'installed':
mozilla.org\mozilla\plugins ; mozilla.org\mozilla\uninstall ;
mozilla.org\mozilla\install_status.log ; mozilla.org\mozilla\install_wizard.log.
I see no error in the log files.

Expected Results:  
Installed Mozilla.

Note that this is almost a dup of bug 195112 (for Win98) which is a VERIFIED
DUPLICATE of bug 195060 which is VERIFIED FIXED.
On Windows 95 there is bug 135570 which is VERIFIED FIXED. Its error message
number is 1114 but it is also about xpistub.dll.

Comment 1

14 years ago
Please have a look at 
Bug 206806 installer does not ensure enough disk space for GRE component
Bug 212781 Install of 1.4 proceeds past notice of insufficient TEMP space;
install seems to proceed, but fails
Bug 183448 having a file called "ns_temp" in %TEMP makes the installer useless

If you are finding a solution or workaround, please post the result.
OS: other → Windows 95
Product: Browser → Seamonkey
(Reporter)

Comment 2

14 years ago
Tried again, same error:
first Mozilla install on freshly installed Windows 95, 64 MB RAM, 1 GB on C
partition, "1157 : Could not load
C:\WINDOWS\TEMP\ns_temp\xpcom.ns\bin\xpistub.dll" repeated several times in a
dialog. The installation finishes with this error dialog.
(Reporter)

Comment 3

14 years ago
Workaround found: MSIE must be installed for Mozilla installation to succeed.

How ironic...

Note that my version of Windows 95 is the first one, without Internet Explorer.
So I installed MSIE 5. Then (after reboot) I was finally able to install Mozilla
without error. I looks like the Mozilla installer depends on some files
installed by MSIE on Windows 95.

I used mozilla-win32-1.7.3-frFR-installer.exe
Summary: ERROR 1157 : Could not load C:\WINDOWS\TEMP\ns_temp\xpcom.ns\bin\xpistub.dll → MSIE must be installed for Mozilla installation to succeed

Comment 4

14 years ago
The problem lies on a way to load dll's and a missing dll that didn't exists on 
first win95 release (maybe also some laters). With the installation of IE the 
missing dll will be installed. 
 
On win95 it is saver to use the .zip files and install manuelly. Maybe try the 
latest version (1.7.6) and report if this also happens with it. 
 
But the problem (if it exists any more) won't be resolved as win95 isn't realy 
supported any more (it's more then 10 years old). 
 
Maybe following bugs help you: 
 
bug 212363 
bug 197692 
 
You should update your windows to latest Version of: 
http://www.microsoft.com/windows95/downloads/contents/WURecommended/S_WUServicePacks/MFCLibrary/Default.asp 
 
but maybe also then you will need to use zip files. 
Would be nice if you can give a report of succes or non succes. 
(Reporter)

Comment 5

14 years ago
If Windows 95 is no more officially supported, I think it should be said in
http://www.mozilla.org/products/mozilla1.x/sysreq.html

Comment 6

14 years ago
But it works with an updated (latest patches and so on) Windows 95 (in my
internet cafe I've it running on all 16 PC's).

But anyway, I'll close it as wfm, cause it works for me maybe it needs a release
note.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.