Error establishing an encrypted connection. Error code: -5990

RESOLVED DUPLICATE of bug 111384

Status

--
major
RESOLVED DUPLICATE of bug 111384
14 years ago
2 years ago

People

(Reporter: onkarshinde, Unassigned)

Tracking

1.0 Branch
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040803

The error mentioned in subject is received on sites that use JSP pages over
secure connection.

Another example is
http://www.baazee.com/customjsp/myBaazee/myBaazee_main.jsp.

The 'Secure Login' button on this page redirects to following page
https://www.baazee.com/jsp/UserLogin.jsp

The site is viewed through a proxy based network and there is no problem in
proxy settings.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.baazee.com/customjsp/myBaazee/myBaazee_main.jsp
2. Put any information as username and password
3. Click "Secure Login"

Actual Results:  
The error received is 
"Error establishing an encrypted connection. Error code: -5990"
followed by an "operation timeout" error.


Expected Results:  
The page should redirect to appropriate profile page of user or an error page
indicating false user information.

Comment 1

14 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a3) Gecko/20040817

Login with test/test, https://www.baazee.com/jsp/UserLogin.jsp is showing:  
Wrong Password or your Baazee ID/Email ID doesn't exist. Please try again
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a3) Gecko/20040817
> 
> Login with test/test, https://www.baazee.com/jsp/UserLogin.jsp is showing:  
> Wrong Password or your Baazee ID/Email ID doesn't exist. Please try again

Please try this link
https://services.vsnl.net/new/buy_online.jsp

If that also works properly then can you please tell me what is error code -5990. 


Onkar Shinde

Comment 3

14 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a3) Gecko/20040817

> 
> Please try this link
> https://services.vsnl.net/new/buy_online.jsp

It is also working, after faking a mailadress and a 7-digit phone number another
page was loaded.

> If that also works properly then can you please tell me what is error code -5990. 
 
I don´t know. But I´m testing with 1.8a3, not 1.7.2, maybe, that makes the
difference. 
(Reporter)

Comment 4

14 years ago
The problem pertained in 1.8a3 also.

It seems that enabling an option in Preferences->Privacy & Security->Validation
that says "Use OCSP to validate only certificates that specify an OCSP service
URL" has caused this problem.

I enabled "Do not use OCSP for certificate validation" and everything is working
fine.
(Reporter)

Updated

14 years ago
Component: Browser-General → Preferences

Comment 5

14 years ago
You can't currently use OCSP if you use a proxy.

*** This bug has been marked as a duplicate of 111384 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Component: Preferences → Client Library
Product: Browser → PSM
Resolution: --- → DUPLICATE
Version: Trunk → 2.4

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

10 years ago
Version: psm2.4 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.