Text fields/areas does not get Chinese (non-English?) input correctly

RESOLVED EXPIRED

Status

()

--
major
RESOLVED EXPIRED
14 years ago
13 years ago

People

(Reporter: pplwong, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040825 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040825 Firefox/0.9.1+

When using MSWindows XP's Chinese IME (pingyin, for example), all text
fields/areas (including the address bar, google bar) cannot get input correctly.

Reproducible: Always
Steps to Reproduce:
Use Chinese IME on XP (pingyin, for example) to type a Chinese word.


Actual Results:  
For example, when typing "是", I get "   失是".

The pinying of "是" is "shi", and a "full character space" is entered for each
of the 3 chars I used to do the pinying (check the above incorrect string and
you'll know what I mean). Then a list of option pop up (on the IME). The 1st
word in the list is "失" (the 4th char in the incorrect string above). And the
2nd word in the list is "是".

The "失" (4th char) is entered when I confirm the pinying, "shi", by pressing
"Enter" key. And the 5th word, "是" is entered when I type "2" to choose the
character.


Expected Results:  
"是" should be outputed when I type "2" to choose the char (as described above),
but the 3 spaces (for "shi") and the first word in the list, "失", should not be
displaced.

This work in Firefox 0.9.3 for sure (I've just tried), and worked in trunk till
sometime within 2 weeks (I think).

If Chinese is having problem, I guess Korean and Japanese and some other
languages may have problem on this also. I'd consider it as quite a serious
problem because I now have problem typing languages that need IME.
(Reporter)

Comment 1

14 years ago
Created attachment 157033 [details]
When I finish typing "shi"
(Reporter)

Comment 2

14 years ago
Created attachment 157034 [details]
When I pressed enter to confirm
(Reporter)

Comment 3

14 years ago
Created attachment 157035 [details]
When I clicked the key '2' to confirm
(Reporter)

Comment 4

14 years ago
Please view this issue in UTF-8 to see the Chinese I typed.

The above 3 attachments are what I've done on build 20040825.
When doing it on FF 0.9.3, only "是" appears, which is correct.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.