Chinese character shown on a particular page

UNCONFIRMED
Assigned to

Status

()

--
minor
UNCONFIRMED
14 years ago
9 years ago

People

(Reporter: Hermann.esser, Assigned: smontagu)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.7.2) Gecko/20040803

I noticed at some pages chinese characters.

Settings are
fonts = Westlich (Windows-1252)
default fonts  = Westlich (Windows-1252) and (ISO-8859-1)

1. Switching from chinese to Western the black rhombus with question mark
changes to £ as it should.

2. I have autodetect set to universal, but apparently it doesn´t work all the time.

I build a new profile but same result. 
Cleared Cash again same result. 
Reinstalled Mozilla completely again same result.


Reproducible: Always
Steps to Reproduce:
There is nothing to do. The problem comes up all the time at there particular page.
Actual Results:  
Characters will shown wrong

Expected Results:  
As on the previous page of example showing the correct characters

If the related link doesnt show the problem I attach a link where you can see a
screen shot of that page.

www.gomfoto.de/Chinese.jpg

see Bugzilla Bug 170229 which covers quite the same years ago.
(Reporter)

Comment 1

14 years ago
Please find attached another example of chinese character into a Western coded page.

www.gomfoto.de/Chinese2.jpg
Product: Browser → Seamonkey

Comment 2

14 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041123

It seems to happen that certain pages that have no character encoding specified
cause the Chinese Simplified encoding to be triggered.  The Chinese character
tends to swallow two to four characters, not just the non-ASCII character that
was intended.  Is this what this bug is about?

My thought is that it should try first to resolve it to an encoding that's
actually in the Active Character Encodings list.

The given URL is defunct - replacing.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 4

13 years ago
I saw it again the other day, but forget where....

Comment 5

13 years ago
worksforme at the given URL with linux seamonkey trunk build 2005100701
(is the bug still supposed to occur with that page?)

==> intl
Assignee: general → smontagu
Component: General → Internationalization
Product: Mozilla Application Suite → Core
QA Contact: general → amyy
QA Contact: amyy → i18n
You need to log in before you can comment on or make changes to this bug.