Location bar should not display encoded URL; should display decoded (plaintext) URL

VERIFIED DUPLICATE of bug 105909

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 105909
15 years ago
15 years ago

People

(Reporter: keith, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

Visit http://kano.net/in/filename%20with%20spaces and the Firefox location bar
will show "http://kano.net/in/filename%20with%20spaces".

I think a more intuitive behavior would be to display
"http://kano.net/in/filename with spaces", since this is the actual text of the
URL before URL-encoding it.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

*** This bug has been marked as a duplicate of 105909 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.