If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

title text disappears too soon if you resize the application

RESOLVED WORKSFORME

Status

Calendar
Sunbird Only
--
enhancement
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Mark Proctor, Unassigned)

Tracking

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040817
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040817

title text disappears if you resize the application

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

13 years ago
Created attachment 157390 [details]
text displayed
(Reporter)

Comment 2

13 years ago
Created attachment 157391 [details]
text hidden
(Reporter)

Comment 3

13 years ago
I appreciate that some would consider this a "feature" and I agree if the boxes
get too small they should not display text, however currently this is too
conservative. I think if it can display atleast 2 or 3 characters then it should
attempt to display the text.

Comment 4

13 years ago
I suggest trying Multiweek view (or Week view) so there is more space available
per day.  You can set the number of weeks in multiweek view, and the number of
previous weeks.
(Reporter)

Comment 5

13 years ago
For now this isn't a problem and I can work with it as is, but I do still think
this is a needed UI enhancement - maybe even a preference to dictate min number
of visible chars before it only displays the icons.

Mark
This bug should probably get "enhancement" in the severity option.

Comment 7

13 years ago
I cant speak for mostafah, but I would RESO/WONTFIX this only because if there
is not enough vertical space for your event to display without overflow, then
there is not enough verticle space...and we resort to the iconic look.

If it was horizontal space causing this I would be willing to work with it, but
that already works as expected.

Mostafah, comments?

Comment 8

13 years ago
Works as intended.
-> WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → WONTFIX

Comment 9

13 years ago
I agree that the current criteria for changing the text to the iconic form is
too conservative. I'll attach a screenshot which displays this better.
Severity: normal → enhancement
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Summary: title text disappears if you resize the application → title text disappears too soon if you resize the application

Comment 10

13 years ago
Created attachment 158759 [details]
Event text replaced by icons when there's relatively enough space required

As you can see in this screenshot, the title of the text is just "test" and it
should fit fine in the blocks. I changed the severity to enhancement to leave
open the possibility of investigating other solutions like:
-Try to use a smaller font before switching to icons.
-Do the iconic change for only the blocks that need them.
Confirming since Mostafa sees this as an issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

12 years ago
QA Contact: gurganbl → sunbird
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody

Comment 13

11 years ago
WFM in the new views.
Status: NEW → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.