events from 2 years ago should not trigger alarms - ever!

RESOLVED DUPLICATE of bug 212076

Status

Calendar
General
--
critical
RESOLVED DUPLICATE of bug 212076
14 years ago
12 years ago

People

(Reporter: JT Moree, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040614 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040614 Firefox/0.8

Every time I try out mozilla it get nowhere because i try to import my calendar
which I have been using in Korganizer for 3 years or more.  Sunbird/calendar
always barfs and crashes over and over again because of the vast amounts of
alarms being generated.  I get to acknowled a few and then it hangs for a long
time.  Messages popup saying i can kill this script bc it is making mozilla run
slowly and I do.  and so on.

My point is,  I NEVER want to see alarms from Jul 18, 2002.  It is stupid.  The
calendar app should have a default period of time that it ignores alarms if they
are before it.  Such as 2 months.

Issues like this have been discussed in bugs like
http://bugzilla.mozilla.org/show_bug.cgi?id=212076
but I dont see this suggestion to fix the problems. 

Reproducible: Always
Steps to Reproduce:
1. import a calendar with years of data
2.
3.

Actual Results:  
sunbird becomes unstable

Expected Results:  
ignored old events
(Reporter)

Comment 2

14 years ago
Yes, notice i mentioned that specifically in the text of the post.

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 212076 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
The suggested solution here is wrong imho. The general rule in programming is to
not introduce magic numbers if not strcitly limited. Why 2 years and not 1 year?
why not 1 month?
So, instead of adding arbitrary limits, let's just make sure the alarms doesn't
cause hangs.

(and if you disagree with a dup, please comment in the original bug, not the bug
it was duped to. If the dup really was wrong, you made offtopic comments in the
other bug)
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.