Closed Bug 257534 Opened 19 years ago Closed 19 years ago

on windows bugzilla should check for activestate perl 5.8.1 or later (for CGI.pm version 2.93)

Categories

(Bugzilla :: Installation & Upgrading, defect)

2.18
x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: glob, Assigned: glob)

Details

Attachments

(1 file, 2 obsolete files)

bugzilla requires CGI.pm version 2.93 or higher, which isn't shipped in
activestate builds until version 5.8.1

activestate perl 5.8.0 ships with CGI.pm version 2.81
activestate perl 5.8.1 ships with CGI.pm version 3.00
Attached patch check for perl 5.8.1 on windows (obsolete) — Splinter Review
Attachment #157496 - Flags: review?(jouni)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 157496 [details] [diff] [review]
check for perl 5.8.1 on windows

>Index: checksetup.pl
>===================================================================
>+if ($^O =~ /MSWin32/i) {
>+    unless ($] >= 5.008001) {
>+        die "Sorry, you need at least ActiveState Perl build 5.8.1\n";
>+        # for CGI 2.93 or higher
>+    }

Move this check _above_ the normal version check, otherwise people with really
old Perls first get told to upgrade to 5.6 and then to 5.8.1. Make sure
documentation/relnotes get updated and notify webtools list about it.

r=jouni
Attachment #157496 - Flags: review?(jouni) → review+
moves version check above normal check
updates rel_notes.txt
Attachment #157496 - Attachment is obsolete: true
Comment on attachment 157712 [details] [diff] [review]
check for perl 5.8.1 on windows v2

carrying forward r=jouni
Attachment #157712 - Flags: review+
Flags: approval2.18?
Flags: documentation?
Flags: documentation2.18?
Flags: approval2.18?
Flags: approval2.18+
Flags: approval+
Target Milestone: --- → Bugzilla 2.18
Hmm, actually, we have a bunch of version 5.6-specific code later on in
checksetup giving different instructions for how to use ppm depending if they
have 5.6 or 5.8.  Since we're effectively no-longer supporting 5.6 on win32,
shouldn't we get rid of that code as well?
good catch dave.  this revision removes the 5.6 specific ppm instructions and
also patches the xml documentation.
Attachment #157712 - Attachment is obsolete: true
Comment on attachment 158189 [details] [diff] [review]
check for perl 5.8.1 on windows (2.18)

i've never done a patch that updated the bugzilla guide, so i'd like another
review.
Attachment #158189 - Flags: review?
Comment on attachment 158189 [details] [diff] [review]
check for perl 5.8.1 on windows (2.18)

looks good to me.  a= still stands.
Attachment #158189 - Flags: review? → review+
can someone please check this in for me?
Trunk:

Checking in checksetup.pl;
/cvsroot/mozilla/webtools/bugzilla/checksetup.pl,v  <--  checksetup.pl
new revision: 1.304; previous revision: 1.303
done
Checking in docs/rel_notes.txt;
/cvsroot/mozilla/webtools/bugzilla/docs/rel_notes.txt,v  <--  rel_notes.txt
new revision: 1.28; previous revision: 1.27
done
Checking in docs/xml/Bugzilla-Guide.xml;
/cvsroot/mozilla/webtools/bugzilla/docs/xml/Bugzilla-Guide.xml,v  <-- 
Bugzilla-Guide.xml
new revision: 1.40; previous revision: 1.39
done
Checking in docs/xml/installation.xml;
/cvsroot/mozilla/webtools/bugzilla/docs/xml/installation.xml,v  <-- 
installation.xml
new revision: 1.75; previous revision: 1.74
done


2.18 branch:

Checking in checksetup.pl;
/cvsroot/mozilla/webtools/bugzilla/checksetup.pl,v  <--  checksetup.pl
new revision: 1.289.2.6; previous revision: 1.289.2.5
done
Checking in docs/rel_notes.txt;
/cvsroot/mozilla/webtools/bugzilla/docs/rel_notes.txt,v  <--  rel_notes.txt
new revision: 1.24.2.4; previous revision: 1.24.2.3
done
Checking in docs/xml/Bugzilla-Guide.xml;
/cvsroot/mozilla/webtools/bugzilla/docs/xml/Bugzilla-Guide.xml,v  <-- 
Bugzilla-Guide.xml
new revision: 1.37.2.2; previous revision: 1.37.2.1
done
Checking in docs/xml/installation.xml;
/cvsroot/mozilla/webtools/bugzilla/docs/xml/installation.xml,v  <-- 
installation.xml
new revision: 1.72.2.3; previous revision: 1.72.2.2
done
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Flags: documentation?
Flags: documentation2.18?
Flags: documentation2.18+
Flags: documentation+
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.