tab group set as home, form focuses on one of the hidden tabs instead of visible tab

VERIFIED DUPLICATE of bug 124750

Status

SeaMonkey
Tabbed Browser
--
minor
VERIFIED DUPLICATE of bug 124750
14 years ago
10 years ago

People

(Reporter: MPH Interactive, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040113

I have a set of tabs configured as my home group; my webmail is the first
(visible tab) and Google is the second or third tab. When I open Mozilla and
start to type without clicking into the password blank first, the typed test (my
password) always goes into the Google search blank on one of the hidden tabs.
Seems like the forms focus should remain on the page/tab that is in front.

I think I've seen this on both PC and Mac platforms, though I normally use Mac.
The behavior has been consistent through the last several revisions of Mozilla.

Great browser, by the way! 

Reproducible: Always
Steps to Reproduce:
1. Set my webmail (http://mphoffice.dns2go.com:3000) as primary tab and Google
as secondary tab; set tab group as default home
2. Close and open Mozilla.
3. Start typing password without clicking into webmail password blank. Typed
text will actually appear in the Google search blank on the second, hidden tab.

Actual Results:  
see step 3 above

Expected Results:  
Mozilla autofills my username into the webmail user blank. If it is going to
allow me to type into a form without clicking in a blank first, I would expect
it to focus on the form on front (visible) tab - either the username or password
blank.

Instead my password gets entered as plain, readable text into the hidden Google
search blank on the second tab.

Thanks!!

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.