If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Page doesn't paint/repaint correctly (GFX scrollbars on GTK)

VERIFIED DUPLICATE of bug 20185

Status

()

Core
Layout: View Rendering
P3
major
VERIFIED DUPLICATE of bug 20185
18 years ago
18 years ago

People

(Reporter: Paul Gartside, Assigned: Eric Vaughan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
(M13 of 27th Jan, Linux i686, standard binary with full circle)



On loading the url above (http://webreview.com/wr/pub/1999/06/18) the following

happens:

1) the usual content loads ok

2) then the ad iframes start loading, at this point the standard content is

destroyed (grey background with a few pieces from original)

3) the ad iframes finish loading, but the rest of the page is trash.

Comment 1

18 years ago
Reassigning to Eric.
Assignee: karnaze → pollmann

Comment 2

18 years ago
If you resize the window does the page paint itself correctly?  I'm not seeing
this bug on today's build (Solaris, will try Linux later).   However, when
scrolling up and down or moving windows in front of the browser on this page,
not all of the regions are repainting correctly.  It would be great if you could
reduce this page to a minimal test  case that still had the problem!  :)
(Reporter)

Comment 3

18 years ago
Created attachment 4766 [details]
Minimal criminal!
(Reporter)

Comment 4

18 years ago
I thought I'd sent a comment before I sent the test case. But apparently not.



So I've tried to make a minimal criminal, as you asked.

Loading this on my standard M13 Jan27, i86 linux, gives a glimpse of the correct

view, then goes completely blank.



Note: 1) removing the <font> tags seems to cure this; 2) the <td> and </form>

tags are in the wrong order.



Hope this helps.

(Reporter)

Comment 5

18 years ago
Oh and in my original comment, I remembered to say that resizing may cause parts
of the view to paint ok, but not necessarily all or even any.

Comment 6

18 years ago
Thanks for the minimal test case!  (criminal :)  )  With today's build, I am
able to reproduce the problem that resizing will sometimes not repaint all or
even any of the page.  It seems that iframes may not have caused this problem
since there are none in the minimal criminal.  I'll take a look and see if I can
figure out what's going on...

Comment 7

18 years ago
This appears to be a GTK only problem, as this testcase paints fine on my
Windows box but is unhappy on Solaris.  CC'ing some gurus.  Pav or Waqar, have
you seen this one before?
Component: HTMLFrames → Views
Summary: Loading iframes destroys rest of page → Page doesn't paint/repaint correctly

Comment 8

18 years ago
Created attachment 4767 [details]
A more minimal criminal. (busted for me anyway)

Comment 9

18 years ago
I have been dealing with these kind of issues for the last two weeks or so. I
just test the minimal attachment, using the gfx scrollbars it is hosed, if I
resize the page all I get is gray. But if you use native scrollbars the page
renders correctly. I this should be passed on to evaughan@netscape.com since he
did the work with gfx scrollbars.

Comment 10

18 years ago
Thanks Waqar, passing to Eric.
Assignee: pollmann → evaughan
Summary: Page doesn't paint/repaint correctly → Page doesn't paint/repaint correctly (GFX scrollbars on GTK)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 11

18 years ago
This is the famous an one of the most annoying bugs. Bug 20185.


*** This bug has been marked as a duplicate of 20185 ***

Comment 12

18 years ago
Marking verified dup of 20185.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.