Firefox doesn't release resources after closing down tab.

RESOLVED DUPLICATE of bug 131456

Status

()

--
critical
RESOLVED DUPLICATE of bug 131456
14 years ago
14 years ago

People

(Reporter: neo-dump, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

Look at this screenshot:
http://www.student.ru.nl/svandegeijn/foutje.jpg

I made a little script, but it went wrong: it kept on looping, so it wouldn't
stop generating a form, that's my bad. But when I close the tab down, look at
the memory still used:

http://www.student.ru.nl/svandegeijn/foutje2.jpg
Allmost 260MB... While the tab has been closed down!

Reproducible: Always
Steps to Reproduce:
1. Build a script that keeps on looping, thus generating a huge page
2. Close down the tab it was opened in
3. Resourses are not freed at all!

Actual Results:  
Same, Mozilla kept using memory

Expected Results:  
Free the unneeded memory
Whiteboard: Dupeme

Comment 1

14 years ago
0.9.2 is outdated. The bug writing guidelines say "be sure that you've
reproduced your bug using a build released within the past three days."

Can  you please retest iwth a nighlty branch build and see if it also occurs there?
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-0.9/

Updated

14 years ago
Summary: Firefox doesn't release resourses after closing down tab. → Firefox doesn't release resources after closing down tab.

Comment 2

14 years ago
More importantly, saying memory leaks after closing a tab isn't very helpful. 
It could be related to any number of issues (page specific, non-page specific,
etc), and
http://bugzilla.mozilla.org/buglist.cgi?keywords_type=allwords&keywords=mlk&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&chfieldto=Now
is a list of currently open memory leak bugs.

What the script specifically did could be a help to either duplicating to
another known bug, or making this a report that developers can use.

Comment 3

14 years ago
This also happens when you open empty tabs... keep opning them, close them, open
some more, close them ... you eat up ALL memory with this method.

This happens with Mozilla AND Firefox. Just keep holding CTRL+T...

I tested it with the lasted Moz (1.8.3a) and the latest Firefox (0.9.3).

*** This bug has been marked as a duplicate of 131456 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Whiteboard: Dupeme
*** This bug has been marked as a duplicate of 131456 ***

*** This bug has been marked as a duplicate of 131456 ***
You need to log in before you can comment on or make changes to this bug.