File upload (during form submission) progress meter no longer working properly

RESOLVED DUPLICATE of bug 249338

Status

()

Core
HTML: Form Submission
--
trivial
RESOLVED DUPLICATE of bug 249338
14 years ago
14 years ago

People

(Reporter: phil, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040820 Debian/1.7.2-4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707

Bug 24197 was an RFE for showing the progress of uploaded files; the bar in
the lower right of the browser window grows to full size as upload nears
completion (the browser knows how much data there is to send, after all).

This stopped working sometime between 1.5 and 1.7.1.  Now, the bar is immediately
filled out to its max size, and remains there while the file is uploaded.


Reproducible: Always
Steps to Reproduce:
1. Find a bog-standard form with file uploading.  The ones I use for my job use
the POST method, but that shouldn't matter (the file size is still known).
2. Submit the form.

Actual Results:  
3. Watch the progress bar on the bottom do nothing.


Expected Results:  
A steady progression from left to right.  :-)
> The ones I use for my job use
> the POST method, but that shouldn't matter (the file size is still known).

yeah well, you can't use GET for file uploads...

Are you seeing this on both windows and linux?

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 249338 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.