Last Comment Bug 257985 - History Window: View|Sorted by menu items do not work
: History Window: View|Sorted by menu items do not work
Status: RESOLVED FIXED
: fixed-seamonkey1.0, regression
Product: Core
Classification: Components
Component: History: Global (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Vidar Haarr (not reading bugmail)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-03 16:56 PDT by Stefan Borggraefe
Modified: 2006-03-25 04:07 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Proposed Fix (3.66 KB, patch)
2004-09-03 17:03 PDT, Stefan Borggraefe
neil: review-
Details | Diff | Splinter Review
version 0.1 (2.39 KB, patch)
2005-09-27 01:13 PDT, Vidar Haarr (not reading bugmail)
jvarga: review-
Details | Diff | Splinter Review
version 0.2 (2.28 KB, patch)
2005-10-05 08:19 PDT, Vidar Haarr (not reading bugmail)
jvarga: review+
neil: superreview+
Details | Diff | Splinter Review

Description Stefan Borggraefe 2004-09-03 16:56:58 PDT
Instead when you select one of them, the following error is displayed on the
JavaScript Console:

Error: column.parentNode has no properties
Source File: chrome://global/content/nsTreeSorting.js
Line: 67

Tested with a Linux trunk build from yesterday.
Comment 1 Stefan Borggraefe 2004-09-03 17:03:18 PDT
Created attachment 157847 [details] [diff] [review]
Proposed Fix
Comment 2 Jan Varga [:janv] 2004-09-22 09:07:08 PDT
The problem is that nsTreeSorting.js was initially developed as a generic
utility, IIRC.
So you shouldn't use |document.getElementById('historyTree')|
Comment 3 Vidar Haarr (not reading bugmail) 2005-09-27 01:13:14 PDT
Created attachment 197528 [details] [diff] [review]
version 0.1
Comment 4 neil@parkwaycc.co.uk 2005-09-27 02:45:29 PDT
Comment on attachment 197528 [details] [diff] [review]
version 0.1

I'm wondering whether we should rename SortColumn to SortColumnElement and add
a new SortColumn method to handle the history tree.
Comment 5 Jan Varga [:janv] 2005-10-01 01:27:28 PDT
(In reply to comment #4)
> (From update of attachment 197528 [details] [diff] [review] [edit])
> I'm wondering whether we should rename SortColumn to SortColumnElement and add
> a new SortColumn method to handle the history tree.
> 

Yeah, SortColumn() will just call document.getElementById() and SortColumnElement()

r=varga
Comment 6 Vidar Haarr (not reading bugmail) 2005-10-05 08:19:47 PDT
Created attachment 198582 [details] [diff] [review]
version 0.2

Something like this?
Comment 7 Jan Varga [:janv] 2005-10-13 11:45:15 PDT
Comment on attachment 198582 [details] [diff] [review]
version 0.2

yes
Comment 8 neil@parkwaycc.co.uk 2005-10-13 12:50:55 PDT
Fix checked in.
Comment 9 neil@parkwaycc.co.uk 2005-12-11 14:00:40 PST
Seamonkey-only portion of fix checked in to the 1.8 branch.

Note You need to log in before you can comment on or make changes to this bug.