browser crashes after I load a URL and clink on a link to another page within the website [@ SBCopyDir32To16()]

RESOLVED DUPLICATE of bug 245407

Status

Core Graveyard
GFX: Mac
--
critical
RESOLVED DUPLICATE of bug 245407
14 years ago
7 years ago

People

(Reporter: margo, Unassigned)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040616

Since upgrading to Mozilla 1.7, when I go to a website, the home page loads but
as soon as I click on a link within the site Mozilla crashes. I then te the
error message "The Application Mozilla has unexpectedly quit" and then a pop-up
window entitled "Welcome to Talkback" opens. I have tried disabling Talkback,
but the problem recurrs when I open Mozilla and go the a website. Note: I am
able to access all the pages within the Mozilla website without the browser
crashing. The site I am most frequently visiting when this error/crash occurs is
http://www.wnyc.org, but it also happens when I go to other website.

Reproducible: Always
Steps to Reproduce:
1.Open Mozilla browswer
2.Go to a URL such as http://www.wnyc.org
3.Click on one of the main navigation links such as "Music"

Actual Results:  
Mozilla crashes; the error message "The Application Mozilla has unexpectedly
quit"; "Welcome to Talkback" pop-up window appears

Expected Results:  
Allow me to surf the web.

"Application Mozilla has unexpectedly quit"

Comment 1

14 years ago
Seems to worksforme with Mozilla 2004083108 on Mac OS 10.2.8. No crash at
http://www.wnyc.org.

margo, please enable Talkback and submit an incident (crashreport). What
Talkback actually does is making it possible for you to send in valuable data
about your crash to mozilla.org. When you submit an incident, you'll notice that
the incident will have a talkback ID. If you post the ID in this bug, developers
might be able to see what's causing the crash.
Keywords: crash
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Seems to worksforme with Mozilla 2004083108 on Mac OS 10.2.8. No 
crash at
> http://www.wnyc.org.
> margo, please enable Talkback and submit an incident (crashreport). 
What
> Talkback actually does is making it possible for you to send in valuable 
data
> about your crash to mozilla.org. When you submit an incident, you'll 
notice that
> the incident will have a talkback ID. If you post the ID in this bug, 
developers
> might be able to see what's causing the crash.

Stephan--

I just enabled Talkback and submitted a report -- I hope I gave enough 
information which was that the Mozilla browser version 1.7 crashes on my 
Mac -- OS X -- when I'm clicking on links within a website. The incident ID 
is TB735845E

Comment 3

14 years ago
GFX: Mac (?)
Component: Browser-General → GFX: Mac
Crash stack from that talkback incident follows.  This looks like a duplicate of
bug 247542... Reporter, could you test Mozilla 1.7.1 or later to verify?  If the
crash goes away, this is a duplicate...

SBCopyDir32To16()
Stretch()
BitsDevLoop()
CommonBits()
StdBits()
CommonBits()
CopyBits()
nsImageMac::Draw()  [/builds/release/1.7/mozilla/gfx/src/mac/nsImageMac.cpp,
line 293]
nsRenderingContextImpl::DrawImage() 
[/builds/release/1.7/mozilla/gfx/src/shared/nsRenderingContextImpl.cpp, line 710]
nsImageFrame::Paint() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsImageFrame.cpp, line 1308]
nsContainerFrame::PaintChild() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 132]
nsContainerFrame::PaintChildren() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 683]
nsHTMLContainerFrame::PaintDecorationsAndChildren() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsHTMLContainerFrame.cpp, line
141]
nsInlineFrame::Paint() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsInlineFrame.cpp, line 337]
nsContainerFrame::PaintChild() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 132]
nsBlockFrame::PaintChildren() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 683]
nsHTMLContainerFrame::PaintDecorationsAndChildren() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsHTMLContainerFrame.cpp, line
141]
nsBlockFrame::Paint() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 5292]
nsContainerFrame::PaintChild() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 132]
nsContainerFrame::PaintChildren() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 683]
nsTableCellFrame::Paint() 
[/builds/release/1.7/mozilla/layout/html/table/src/nsTableCellFrame.cpp, line 476]
nsContainerFrame::PaintChild() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 132]
nsContainerFrame::PaintChildren() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 683]
nsTableRowFrame::Paint() 
[/builds/release/1.7/mozilla/layout/html/table/src/nsTableRowFrame.cpp, line 570]
nsTableRowGroupFrame::PaintChildren() 
[/builds/release/1.7/mozilla/layout/html/table/src/nsTableRowGroupFrame.cpp,
line 287]
nsTableRowGroupFrame::Paint() 
[/builds/release/1.7/mozilla/layout/html/table/src/nsTableRowGroupFrame.cpp,
line 235]
nsContainerFrame::PaintChild() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 132]
nsContainerFrame::PaintChildren() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 683]
nsTableFrame::PaintChildren() 
[/builds/release/1.7/mozilla/layout/html/table/src/nsTableFrame.cpp, line 1383]
nsTableFrame::Paint() 
[/builds/release/1.7/mozilla/layout/html/table/src/nsTableFrame.cpp, line 1456]
nsContainerFrame::PaintChild() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 132]
nsTableOuterFrame::Paint() 
[/builds/release/1.7/mozilla/layout/html/table/src/nsTableOuterFrame.cpp, line 683]
nsContainerFrame::PaintChild() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 132]
nsBlockFrame::PaintChildren() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 683]
nsHTMLContainerFrame::PaintDecorationsAndChildren() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsHTMLContainerFrame.cpp, line
141]
nsBlockFrame::Paint() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 5292]
nsContainerFrame::PaintChild() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 132]
nsBlockFrame::PaintChildren() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 683]
nsHTMLContainerFrame::PaintDecorationsAndChildren() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsHTMLContainerFrame.cpp, line
141]
nsBlockFrame::Paint() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 5292]
nsContainerFrame::PaintChild() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 132]
nsContainerFrame::PaintChildren() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 683]
nsHTMLContainerFrame::Paint() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsHTMLContainerFrame.cpp, line 89]
CanvasFrame::Paint() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsHTMLFrame.cpp, line 394]
PresShell::Paint() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsPresShell.cpp, line 5567]
nsView::Paint()  [/builds/release/1.7/mozilla/view/src/nsView.cpp, line 260]
nsViewManager::RenderDisplayListElement() 
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp, line 1429]
nsViewManager::RenderViews() 
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp, line 1347]
nsViewManager::Refresh() 
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp, line 906]
nsViewManager::DispatchEvent() 
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp, line 704]
HandleEvent()  [/builds/release/1.7/mozilla/view/src/nsView.cpp, line 80]
nsWindow::DispatchEvent() 
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp, line 2024]
nsWindow::DispatchWindowEvent() 
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp, line 2047]
nsWindow::UpdateWidget() 
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp, line 1731]
nsWindow::UpdateWidget() 
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp, line 1768]
nsWindow::UpdateWidget() 
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp, line 1768]
nsWindow::UpdateWidget() 
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp, line 1768]
nsWindow::UpdateWidget() 
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp, line 1768]
nsWindow::PaintUpdateRectProc() 
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp, line 1313]
nsWindow::HandleUpdateEvent() 
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp, line 70]
nsWindow::Update()  [/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp,
line 1276]
nsViewManager::Composite() 
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp, line 1591]
nsViewManager::EnableRefresh() 
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp, line 3154]
nsViewManager::EndUpdateViewBatch() 
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp, line 3190]
PresShell::FlushPendingNotifications() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsPresShell.cpp, line 5124]
nsDocument::FlushPendingNotifications() 
[/builds/release/1.7/mozilla/content/base/src/nsDocument.cpp, line 3937]
nsContentTreeOwner::SetStatus() 
[/builds/release/1.7/mozilla/xpfe/appshell/src/nsContentTreeOwner.cpp, line 384]
GlobalWindowImpl::SetStatus() 
[/builds/release/1.7/mozilla/dom/src/base/nsGlobalWindow.cpp, line 65]
_XPTC_InvokeByIndex()   XPCWrappedNative::CallMethod(XPCCallContext&,
XPCWrappedNative::CallMode)() 
[/builds/release/1.7/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2027]
XPC_WN_GetterSetter() 
[/builds/release/1.7/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1312]
js_Invoke()  [/builds/release/1.7/mozilla/js/src/jsinterp.c, line 941]
js_InternalInvoke()  [/builds/release/1.7/mozilla/js/src/jsinterp.c, line 1036]
js_InternalGetOrSet()  [/builds/release/1.7/mozilla/js/src/jsinterp.c, line 1079]
js_SetProperty()  [/builds/release/1.7/mozilla/js/src/jsobj.c, line 2773]
js_Interpret()  [/builds/release/1.7/mozilla/js/src/jsinterp.c, line 2164]
js_Invoke()  [/builds/release/1.7/mozilla/js/src/jsinterp.c, line 958]
js_InternalInvoke()  [/builds/release/1.7/mozilla/js/src/jsinterp.c, line 1036]
JS_CallFunctionValue()  [/builds/release/1.7/mozilla/js/src/jsapi.c, line 3614]
nsJSContext::CallEventHandler() 
[/builds/release/1.7/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1299]
nsJSEventListener::HandleEvent() 
[/builds/release/1.7/mozilla/dom/src/events/nsJSEventListener.cpp, line 177]
nsEventListenerManager::HandleEventSubType() 
[/builds/release/1.7/mozilla/content/events/src/nsEventListenerManager.cpp, line
710]
nsEventListenerManager::HandleEvent() 
[/builds/release/1.7/mozilla/content/events/src/nsEventListenerManager.cpp, line
1512]
nsGenericElement::HandleDOMEvent() 
[/builds/release/1.7/mozilla/content/base/src/nsGenericElement.cpp, line 1964]
nsGenericHTMLElement::HandleDOMEventForAnchors() 
[/builds/release/1.7/mozilla/content/html/content/src/nsGenericHTMLElement.cpp,
line 1365]
nsGenericElement::HandleDOMEvent() 
[/builds/release/1.7/mozilla/content/base/src/nsGenericElement.cpp, line 1994]
nsHTMLImageElement::HandleDOMEvent() 
[/builds/release/1.7/mozilla/content/html/content/src/nsHTMLImageElement.cpp,
line 578]
nsEventStateManager::DispatchMouseEvent() 
[/builds/release/1.7/mozilla/content/events/src/nsEventStateManager.cpp, line 2500]
nsEventStateManager::GenerateMouseEnterExit() 
[/builds/release/1.7/mozilla/content/events/src/nsEventStateManager.cpp, line 2618]
nsEventStateManager::PreHandleEvent() 
[/builds/release/1.7/mozilla/content/events/src/nsEventStateManager.cpp, line 436]
PresShell::HandleEventInternal() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsPresShell.cpp, line 710]
PresShell::HandleEvent() 
[/builds/release/1.7/mozilla/layout/html/base/src/nsPresShell.cpp, line 5928]
nsViewManager::HandleEvent() 
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp, line 61]
nsViewManager::DispatchEvent() 
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp, line 2025]
HandleEvent()  [/builds/release/1.7/mozilla/view/src/nsView.cpp, line 80]
nsWindow::DispatchEvent() 
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp, line 2024]
nsWindow::DispatchWindowEvent() 
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp, line 2040]
nsWindow::DispatchMouseEvent() 
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp, line 2066]
nsMacEventHandler::HandleMouseMoveEvent() 
[/builds/release/1.7/mozilla/widget/src/mac/nsMacEventHandler.cpp, line 1751]
nsMacEventHandler::HandleOSEvent() 
[/builds/release/1.7/mozilla/widget/src/mac/nsMacEventHandler.cpp, line 551]
Depends on: 247542
Summary: browser crashes after I load a URL and clink on a link to another page within the website → browser crashes after I load a URL and clink on a link to another page within the website [@ SBCopyDir32To16()]
(Reporter)

Comment 5

14 years ago
Not sure I understand the above info. I'm on a Mac and it seems 1.7.1 is 
for Windows? Anyway, any website I've visited using Mozilla keeps 
crashing once I start clicking around in the site -- Except for Mozilla's site 
itself! Perhaps this is a persistant Mac problem? I'm using OS 10.2.8.

Comment 6

14 years ago
margo, see
http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.7.2/mozilla-mac-1.7.2.dmg.gz
can you report back if it works fine ?
(Reporter)

Comment 7

14 years ago
(In reply to comment #6)
> margo, see
> 
http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.7.2/mozilla-
mac-1.7.2.dmg.gz
> can you report back if it works fine ?

I just deleted the older version of Mozilla 1.7 and installed 1.7.2 (from the 
URL above) and I'm still having the same problem. The browser Mozilla 
crashed when I click around within a website.
(Reporter)

Comment 8

14 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; 
en-US; rv:1.7) Gecko/20040616
> Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; 
en-US; rv:1.7) Gecko/20040616
> Since upgrading to Mozilla 1.7, when I go to a website, the home page 
loads but
> as soon as I click on a link within the site Mozilla crashes. I then te the
> error message "The Application Mozilla has unexpectedly quit" and then 
a pop-up
> window entitled "Welcome to Talkback" opens. I have tried disabling 
Talkback,
> but the problem recurrs when I open Mozilla and go the a website. Note: 
I am
> able to access all the pages within the Mozilla website without the 
browser
> crashing. The site I am most frequently visiting when this error/crash 
occurs is
> http://www.wnyc.org, but it also happens when I go to other website.
> Reproducible: Always
> Steps to Reproduce:
> 1.Open Mozilla browswer
> 2.Go to a URL such as http://www.wnyc.org
> 3.Click on one of the main navigation links such as "Music"
> Actual Results:  
> Mozilla crashes; the error message "The Application Mozilla has 
unexpectedly
> quit"; "Welcome to Talkback" pop-up window appears
> Expected Results:  
> Allow me to surf the web.
> "Application Mozilla has unexpectedly quit"

(In reply to comment #7)
> (In reply to comment #6)
> > margo, see
> > 
> 
http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.7.2/mozilla-
> mac-1.7.2.dmg.gz
> > can you report back if it works fine ?
> I just deleted the older version of Mozilla 1.7 and installed 1.7.2 (from the 
> URL above) and I'm still having the same problem. The browser Mozilla 
> crashed when I click around within a website.

I've given up using Mozilla for now as a browser, since it's still crashes 
even on startup.

Comment 10

14 years ago
There are several QD crash bugs open. I am not sure which are dups.

Bug 275120 "Crash on page with multiple BMPs with specified width [@ QD.150.6.0
+ 0x1ea74 (0x9753aa74) c273aa71]" seems to be a close match, but you might want
to mark as a dependency on Bug 216397 "crashes when attempting to load bitmap 
files [@ nsImageMac::CopyBitsWithMask]" where there are more people reading.

See bug 262549, bug 253286 and bug 207553

Comment 11

13 years ago
This was probably fixed by the patch for Bug 245407 "Convert nsImageMac to use 
Quartz instead of Quickdraw"

Comment 12

13 years ago
wfm.
I think that this problem does all fix. 
Please re-open if you reproduce. 

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.7) Gecko/20050417
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.8b2) Gecko/20050423
Firefox/1.0+
Camino trunk build 2005042322 (v0.8+)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
If it works for you, proper resolution is WORKSFORME.  Nothing was fixed by this
bug.  Correct resolution is dup of bug 245407.

*** This bug has been marked as a duplicate of 245407 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
Crash Signature: [@ SBCopyDir32To16()]
You need to log in before you can comment on or make changes to this bug.