Can't delete a saved query when the query no longer matches any bug.

RESOLVED DUPLICATE of bug 232176

Status

()

Bugzilla
Query/Bug List
--
trivial
RESOLVED DUPLICATE of bug 232176
14 years ago
5 years ago

People

(Reporter: Steve Palmer, Assigned: justdave)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Bugzilla Version 2.17.6

I created several queries which searched for a specific target milestone, such 
as "4.7.3.4". I named the saved query using our product name and version, such 
as "RefMgr 4.7.3.4". During the course of our project, I changed the target 
milestone to 4.7.3.5, 4.7.3.6, etc. and I DELETED the original 4.7.3.4 target 
milestone. The saved query no longer match any bug. I do not see an option to 
delete a saved query unless it finds at least one bug.

I created saved searches for 3 different projects -- I have accumulated 
several saved searches which I cannot delete.

I tried to create a "dummy" bug with the original target milestones so that 
the saved query finds at least one record (so the delete saved query option 
becomes available). With one saved query Bugzilla reported the saved query was 
been deleted, but the query name remains displayed in the saved queries list. 
With the two other saved queries, I was not able to create a "dummy" bug which 
matched the saved query (I must have included some search criteria besides 
target milestone, but that was many weeks ago and I don't recall which).

Reproducible: Always
Steps to Reproduce:
See Details.
Actual Results:  
I have not found a way to delete saved queries which no longer match any 
existing bug. [I am able to successfully delete any query (BugZilla offers the 
option to delete after query executes), provided the query matches at least 
one existing bug.]

Expected Results:  
I expected to be able to delete a saved query whether it still matches 
existing bugs or not. I expected to find an option which allowed me to delete 
a saved query whether the query is run or not.

Our BugZilla administrator does not know of a way to delete saved queries 
which no longer match any existing bug. If documentation is available, please 
let us know where we can find it!
OS: Windows XP → All
Hardware: Macintosh → All
This was fixed in bug 232176.

For 2.17.x, you can work aroung by doing some dummy search and saving it with
the name of a saved search you wish to delete. This updates your old saved
search, and you can delete it the usual way afterwards.
if this is on bugzilla.mozilla.org, see also
http://bugzilla.mozilla.org/page.cgi?id=saved-searches.html

*** This bug has been marked as a duplicate of 232176 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.