Closed Bug 258336 Opened 19 years ago Closed 18 years ago

Using http/ as the start of the URL jumps to Microsoft.com

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 231720

People

(Reporter: jrose, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040803 Firefox/0.8 StumbleUpon/1.995
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040803 Firefox/0.8 StumbleUpon/1.995

If the protocol is http, and followed by a slash instead of a colon (eg:
http//:whiteshell.com, http/whiteshell.com, http/:/whiteshell.com), the browser
loads microsoft.com instead of the domain listed.

Reproducible: Always
Steps to Reproduce:
1. Highlight the Location field (you know, where the URL, er, URI goes)
2. Type "http/anything.org" 
3. Press "Enter"

Actual Results:  
Microsoft.com loaded into the content area.

Expected Results:  
I guess I'd like it to read my mind and recognize that I transposed some characters.

I found a link on boingboing that was broken in this way, and so I decided to
try it with other URLs. You need a bug severity level for "Funny."
Firefox is treating it as a search keyword.  If you enter search terms in the
address field, Firefox will return the result of a "I'm Feeling Lucky" search at
Google.

And if you do such a search for 'http//' at Google, the first result is
microsoft.com.


*** This bug has been marked as a duplicate of 235478 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Summary: Using http/ as the start of the URL jumps to Microsoft.com → Using http/ as the start of the URL jumps to Microsoft.com
Status: RESOLVED → VERIFIED
231720 
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 231720 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago18 years ago
Resolution: --- → DUPLICATE
Verifying old and obvious dupes. Sorry for bugspam.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.