Closed Bug 258354 Opened 15 years ago Closed 15 years ago

block xpi install bar should give option to temporarily allow installation

Categories

(Toolkit :: Add-ons Manager, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 252830

People

(Reporter: seth, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040901 Firefox/1.0 PR (NOT FINAL)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040901 Firefox/1.0 PR (NOT FINAL)

When installing an XPI from a non-trusted site, the Information Bar appears to
tell the user that the XPI has been blocked. The user must "Edit Options..." and
click Allow, and then click the XPI's link again to retry the install request.
There should be a button next to "Edit Options..." to "Allow This Time", so an
XPI can be installed from a site which one will never visit again. Saves time.

Reproducible: Always
Steps to Reproduce:
1. Click XPI install link from "non-trusted" site
2. Information Bar appears

Actual Results:  
3. Must "Edit Options..." to allow install

Expected Results:  
3. "Allow This Time" button to allow XPI install this time only.

*** This bug has been marked as a duplicate of 252830 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.