If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot get proxy to work, when it does work with Explorer

RESOLVED WORKSFORME

Status

()

Core
Networking: HTTP
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: lethin2002, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040803

I'm not successful at getting a proxy configuration.  The proxy server is
http://copy.its.yale.edu:8080.  When I configure this, I get an error message
trying to access any page.  Related to this, it seems to matter if the http://
is included or not in the name of the proxy server.  

Reproducible: Always
Steps to Reproduce:
1. Set Edit->Preferences->Advanced->Proxies
2. Set up Manual configuration 
3. Server is copy.its.yale.edu, port is 8080
4. OK, then go to any web page

Actual Results:  
Get error message:

Forbidden
You don't have permission to access http://www.google.com/ on this server.

Apache/1.3.26 Ben-SSL/1.48 Server at www-proxy.cis.yale.edu Port 8080

Expected Results:  
Gone to the authentication web page, let me log in.


Maybe this is a bug with Yale's proxy server?

Comment 1

13 years ago
It is a PAC. Use "Automatic proxy configuration URL" and put
http://copy.its.yale.edu:8080 in it. This should work.

Comment 2

13 years ago
(In reply to comment #1)
> It is a PAC. Use "Automatic proxy configuration URL" and put
> http://copy.its.yale.edu:8080 in it. This should work.

Like ostgote said (PAC = Proxy Automatic Configuration). Most PAC urls contains
a filename (proxy.pac for example), but this one looks like a hostname, and a
user might be tempted to fill in the information in the manual fields (hostname
and port). Note that the full URL is actually
<http://copy.its.yale.edu:8080/proxy.pac>.

This is a dupe of bug 30387 : Netscape 4 used URL's in the field for the manual
proxy, but Mozilla uses hostnames. If a user follows old instructions, the
configuration doesn't work.

*** This bug has been marked as a duplicate of 30387 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 3

13 years ago
Stupid me. This isn't a dupe of bug 30387.

The real bug is that the user took the hostname and port from
<http://copy.its.yale.edu:8080> (not realizing that it was really a PAC url),
and filled that in the manual fields.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.